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1-1. What is MED64 the Mobius?

Chapter 1

Introduction

1-1. What is MED64 the Mobius?

MED64 Mobius is the data acquisition and analysis software for the MED64 Systems. It allows MED64
users to acquire signals and analyze each of the 64 channels during and after acquisition. Mobius consists of various moduleswhich correspond to task-specific control panels. You can design your own
experimental protocol as your own "Workflow" by combining these modules using Mobius Editor, and
then run those workflows both for acquisition and analysis. Pre-defined workflow templates are available so that you can run standard types of experiments immediately or design your own workflow easily
by modifying them.
The goal of this Mobius Tutorial is to enable a quick, smooth start working with the Mobius software.
Please refer to Mobius' on-line Help for detailed information about the software.
The following chart shows all the modules and their brief explanations. You can see which modules are
included in the package you purchased.

Representative Mobius packages
1.
2.
3.
4.
5.
6.
7.
8.

Basic (MED-MS64MR10)
EPSP (MED-MS64MR11)
Spike Sorter (MED-MS64MR12)
Spike Sorter with stim (MED-MS64MR13)
Pro (MED-MS64MR14)
QT (MED-MS64MR21)
QT with Stim (MED-MS64MR22)
Extended (MED-MS64MR02)
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Modules for Mobius
Modules

Module description

Acquire MED64R2 Data

Set acquisition parameters and acquires spontaneous activities

Acquire MED64R2 Data w/Stim

Programs stimulation protocols and acquires evoked responses

Acquire MED64R2 w/Pacing

Programs stimulation protocols and acquire evoked responses

Replay Raw Data File

Replays previously acquired data

Display All Channels

Displays data at all 64 channels

Display Single Channel

Displays data at a selected single channel

Export Raw Data

Exports the raw data to a binary or ASCII file

Extract EP Measures

Extracts evoked responses, computes and plots various waveform analysis
(amplitude, slope, time, etc.)

Save Measures Data

Saves data measured with Extract EP (or Spike Measures) as a “csv” file

Compute Measure Averages

Computes measured averages and standard deviations for all experimental
phases and plots the data

Save Measure Averages

Saves the Compute Measure Averages data as a “csv” file

Extract Spikes Advanced

Sets the thresholds and extracts the spikes which go over pre-determined
thresholds

Cluster Spikes

Clusters the extracted spikes into group by shape similarity

Compute Spike Freqs

Builds a chart of spike frequency over time

Display Extracted Spikes (traces
only)

Displays spikes’ extractions

Display Extracted Spikes
(waveforms only)

Displays extracted spikes’ waveforms

Display Spike Frequencies

Display spike frequencies chart

Save Spikes

Saves extracted spikes / Time stamp as a “csv” file

Save Spike Freqs

Saves the spike frequency data as a “csv” file

Extract Spikes

Sets the thresholds and extracts the spikes which cross pre-determined thresholds (old version of Extract Spike Advanced)

Display Spike Measures

Display spikes’ extractions, extracted spikes’ waveforms, and spike frequency
chart.

Extract Long Spikes

Detects and extracts the long spikes (>50ms) crossing pre-determined
thresholds

Display Extracted Spikes

Displays the process of detecting spikes and extracted spikes waveforms

Compute Beats per Minute

Computes beats per minute

Display Beats per Minute

Graphs the beats per minute

Save Beats per Minute

Saves the computed beats per minute as a “csv” file

Compute Interspike Intervals

Builds a time chart of Inter-spike intervals (the time between each successive
spikes)

2
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Modules

Module description

Display Interspike Intervals

Displays the graph of Interspike Intervals

Save Interspike Intervals

Saves the computed inter spike intervals as a “csv” file

Extract Spike Measures

Computes and plots various extracted spike waveform analysis (amplitude,
slope, time, etc) of extracted spikes

Display Results Table

Displays cumulative results from Extracted EP (Spike) Measures and Compute
Measure Averages in a table

Extract Long Spikes (single
channel)

Detects and extracts the long spikes (>50ms) crossing pre-determined thresholds at a selected channel

Display 4x4 channels

Display data at 16 (4x4) channels

Display 2x4 channels

Display data at 8 (2x4) channels

Display Remaining Time

Display the remaining time in a trace

Diaplay Micrograph

Open and display a graphic file

Filter Spike Data

Filters extracted spikes

Filter Raw Data

Filters raw data

Please note: Acquire MED64 Data / Acquire MED64 Data w/Stim are modules for SU-MED640 amplifier.
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Availabilities for modules by packages

Modules / Package
Acquire MED64R2 Data

Basic

EPSP

Spike
Sorter

Spike
sorter
w/stim

Pro

QT

QT
w/stim

Extend
ed

*

*

*

*

*

*

*

*

*

*

*

*

*

*

Acquire MED64R2 Data w/Stim

*

Acquire MED64R2 w/Pacing
Replay Raw Data File

*

*

*

*

*

*

*

*

Display All Channels

*

*

*

*

*

*

*

*

Display Single Channel

*

*

*

*

*

*

*

*

Export Raw Data

*

*

*

*

*

*

*

Extract EP Measures

*

*

*

*

Save Measures Data

*

*

*

*

Compute Measure Averages

*

*

*

*

*

*

*

Save Measure Averages

*

*

*

*

*

*

*

Extract Spikes Advanced

*

*

*

*

Cluster Spikes

*

*

*

*

Compute Spike Freqs

*

*

*

*

Display Extracted Spikes (traces
only)

*

*

*

*

Display Extracted Spikes
(waveforms only)

*

*

*

*

Display Spike Frequencies

*

*

*

*

Save Spikes

*

*

*

Save Spike Freqs

*

*

*

*

Extract Spikes

*

*

*

*

Display Spike Measures

*

*

*

*

*

*

*

Extract Long Spikes

*

*

*

Display Extracted Spikes

*

*

*

Compute Beats per Minute

*

*

*

Display Beats per Minute

*

*

*
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Modules / Package

Spike
Sorter

Spike
sorter
w/stim

QT

QT
w/stim

Extend
ed

Save Beats per Minute

*

*

*

Compute Interspike Intervals

*

*

*

Display Interspike Intervals

*

*

*

Save Interspike Intervals

*

*

*

Extract Spike Measures

*

*

*

Display Results Table

*

*

*

Extract Long Spikes (single
channel)

*

*

*

Basic

EPSP

Pro

Display 4x4 channels

*

*

*

*

*

*

*

*

Display 2x4 channels

*

*

*

*

*

*

*

*

Display Micrograph

*

*

*

*

*

*

*

*

Display Remaining Time

*

*

*

*

*

*

*

*

*

*

*

*

*

*

Filter Spike Data
Filter Raw Data

*

*

*
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1-2. Installation of Mobius and your acquisition PC

1-2.1. Installation of Mobius
The latest version of Mobius is available from the web site:
http://www.med64.com/products/trialsoftware.html
Mobius requires the amplifier-driver to be run for acquisition. Please download the driver from the same
web site.

1-2.2. Settings for your acquisition PC
NOTE:
Ask your local distributor or support@med64.com for the latest requirements and specifications for
your acquisition PC.

Display setting
•

When a display monitor with a resolution of 1920 x 1080 is used, set the Windows 7 text size
([Control Panel] > [Appearance and Personalization] > [Display]) to “Smaller” (100%). Otherwise,
some modules are not displayed correctly.

Figure1-2.1. Display setting.

Language Setting
•

Set the “Decimal symbol” to “period” (.). Mobius does not work properly with the “comma” (,) setting for the decimal symbol. Go to [Control panel] > [Clock, Language, and Regions]. Open the
[Format], and change the “Decimal symbol” to “period” (.).

Figure 1-2.2. Selecting. (period) for the “Decimal symbol”.
6
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Following initial-settings, 1-4 (below) are recommended for stable recording. They are strongly recommended when long-term acquisitions (e.g., days) are performed.

1) Adding second hard drive
Save data to a drive where the operating system is NOT installed (e.g., D drive). For a desktop PC, use
an internal second hard drive. For a laptop PC, use a hard drive with e-SATA (or USB3) connection.
NOTE:
Mobius creates temporal "cache file" on the C drive whenever acquisition is made. This cache file is kept
until the acquisition is stopped. (It is deleted automatically when acquisition is stopped.) Saving data to
a second hard drive helps PC to avoid stopping due to insufficient disk space.

2) Setting for [Power Option]
Change the [Power Option] as following to achieve stable power supply. Unstable power supply could
cause PC to stop due to "buffer overflow".
1.
2.
3.
4.
5.
6.
7.

Go to [Control panel] > [Power Option].
Select [High performance], and then click the [Change Plan Setting].
Select "Never" for the [Computer to Sleep]. (Figure 1-2.3, left)
Click [Change advanced power settings].
Go to [Hard disk] > [Turn off hard disk after]. Select "Never" both on Plugged in and on Battery.
(Figure 1-2.3. Middle)
Go to [USB settings] > [USB selective suspend setting]. Select "Disabled" in both options. (Figure
1-2.3, Right)
Click [OK] to save the changes.

Figure 1-2.3. Setting for Power Option.
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3) Setting for [Advanced system settings]
Increase the "virtual memory" to avoid overloading the PC due to memory shortage with following procedures.
Mobius usually uses up to 3Giga Bite to run. However, it could use more than 3GB when acquisition is
made for long-term. Increasing the "virtual memory" helps the PC to keep running without stopping
when long-term recording is performed.
1.
2.
3.
4.
5.

Right-click the [Computer], and then select the [Properties].
Click the [Advanced system settings].
Select the [Advanced] tab, and click the [Settings] for "Performance". The [Performance Option]
window pops up.
Select [Advanced] tab. Click [Change] for "Virtual memory". Uncheck the "Automatically manage
paging file size for all drives" (Figure 1-2.4, left).
Select [No paging file] for the C drive. Select [Custom size] for the D drive, and then input 12000
for both [Initial Size] and [Maximum Size] (Figure 1-2.4. right). Click [Set], and finally [OK].

Figure 1-2.4. Setting “Virtual memory” in the [Advanced system settings] for C drive (left) and D drive (right).
If the 2nd drive does not exist, select the [Custom size], and then input 12000 for[Initial Size] and
[Maximum size] (Figure 1-2.5) Click [Set], and finally [OK] (Figure 1-2.5).

Figure 1-2.5. Setting the “Virtual memory” for a single drive.
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4) Setting for [Intel Rapid Technology]
Change the setting for [Intel Rapid Technology] as following to achieve stable power supply to hard
disc.
1.
2.

Go to [All programs] > Open the [Intel] folder.> Click [Intel Rapid Storage Technology].
Open the [Performance] tab. Select "Disable" for the [Link power management].

1-2.3. Activation
Mobius needs to be activated with your key-file.
1.
2.
3.

Save the key-file in the [Program file] > [WitWerx] >[Mobius] folder.
Open Mobius. Click [Help] > [Activation].
You will see your Hardware serial # in the box. Click the box next to the Keyfile box to select your
key-file. Click OK for activation.

Figure 1-2.6. Activating Mobius.
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1-3. Important notice for the MED64 Mobius
Please read and follow the instructions below particularly during data acquisition.

General
•

Connect your PC to the MED64 Head amplifier and Main amplifier and turn on both amplifiers to
open [Acquire MED64R2 Data], [Acquire MED64R2 Data w/Stim], or [Acquire MED64R2 Data
w/pacing] modules, or recording workflows including those modules.

•

Make sure that your MED64PC's C drive has at least 50% free space.

•

Make sure that the hard drive has enough free space when you start a long-term recording.
Recording with all 64 channels for 1 hour creates a 9.216GB data file.
(9.216GB is represented as 9,000,000KB, 8,739.06MB, or 8.58GB in the Windows.)

•

Avoid saving data to the drive where the OS is installed (usually C drive). Save it to a separate hard
drive, that is internal or eSATA-supported (See the page 6 in detail).

•

When a recording workflow is run with Green
or Green-Red button for the first time after it
is opened (or made), Mobius needs several
seconds for the calibration (as seen in the
pop-up message). Acquisition starts automatically after the calibration.
If you would like to start acquisition immediately after clicking the Green-Red button, run
the workflow with the Green button for several
seconds, and then stop it before starting your
experiment. When the workflow is run the
next time, it will not require the calibration
and acquisition will start immediately.

•

Figure 1-3.1. Initial calibration (left). Acquisition starts
after the calibration (right).

When running the [Acquire MED64R2 Data] module after running [Acquire MED64R2 Data w/Stim]
or [Acquire MED64R2 w/Pacing], the channels previously used for stimulation are disabled (as seen
in the Figure 1-3.2) and will not record. To activate these channels, one of two methods can be
used:
1)

Open and run a NEW workflow including the [Acquire MED64R2 Data] module.

2)

Run the [Acquire MED64R2 Data w/Stim] module for more than one trace while disabling all
stimulation options (uncheck all the stimulators, Figure 1-3.3), and then run [Acquire MED64R2]
module.

10
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Figure 1-3.2. (left) Example of disabled channel (ch26).
Figure 1-3.3. (right) Disabling the stimulator. Uncheck the“Stim” box for all stimulators, and then run workflow.

•

When a display monitor with a resolution of 1920 x 1080 is used, set the Windows 7 text size
([Control Panel] > [Appearance and Personalization] > [Display]) to “Smaller” (100%). Otherwise,
some modules are not displayed correctly.

•

Set the “Decimal symbol” to “period” (.). Mobius does not work properly with the “comma” (,) setting for the decimal symbol. Go to [Control panel] > [Clock, Language, and Regions]. Open the
[Format], and change the “Decimal symbol” to “period” (.). Or. select “English (US)” for the “Language”.

Acquire MED64R2 Data w/Stim
•

Make sure that the STIMULUS CURRENT selection on the MED64 Head amplifier (MED-A64HE1) is
set to [NORMAL] to deliver the stimulus current amplitude set in Mobius. Selecting [x2] doubles the
output stimulus current amplitude set in Mobius.
(e.g. When 100 A is selected by Mobius while [x2] is selected on the head amplifier, the output
stimulus current is 200 A)

•

The maximum number of pulses for a [Step] in the "Stimulus waveform editor" (#12 in the Fig.
2-1.4, page 15) is 21.

Replay Raw Data
•

Opening a large data file can take several minutes. (e.g. Opening a 10GB file takes over 1 minute.)

•

Mobius processes data in blocks of 500 msec. For replaying data, the Trace Time duration must be
≥501 msec.

Display All Channels
•

For the data to be displayed properly in the Display All Channels module, you must set the Duration (ms/div) to 100 ms/div or greater. Mobius processes data in blocks of 500 msec and always
displays 5 divisions of time in each display channel. Displaying less than 100 ms/div will result in
cutting off some of the data display. For example, setting 20 ms/div results in a display of the first
100 msec of the 500 msec of data processes by Mobius (20 msec x 5 div). The other 400 msec of
data will not be displayed and the next update to the display will again be the first 100 msec of the
next 500 msec batch of data acquired. Conversely, for shorter duration applications (e.g., fEPSPs),
shorter duration recordings are not a problem.
Mobius Tutorial (MED-A64MD1): Chapter 1-Introducion
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Extract Spikes Advanced / Extract Spikes / Extract Long Spikes
•

These modules require powerful computation and need to be used carefully during acquisition.
Mobius can appear to freeze when it extracts more spikes than it can analyze. This most often happens when non-biological signals cross the spike extraction thresholds on all channels at once. (e.g.
unexpected noises cross the thresholds or the baseline fluctuates due to vibration.) Please keep in
mind the following instructions when these workflows are used with acquisition.

•

Avoid using these modules on-line (during signal acquisition) until you are familiar with your experiment(s) and biological assay(s). Particularly avoid using these modules for long-term recordings.

•

Set the trace duration to less than 10 minutes and the trace interval for longer than the trace duration so that the extracting spikes can catch up with acquisition during the trace interval.

•

For recording neuronal spikes, make sure to set the low-cut filter to 100 Hz in order to remove
low-frequency noise.

•

Make sure to PAUSE Mobius when drugs are applied.

•

Minimize the number of channels for spike extraction.

Filter Raw Data
•

Mobius acquires data in 500 msec blocks. Digital filtering can cause small noise spikes to appear at
the end of a data block if the baseline is offset from 0 at the end of the data blocks. To eliminate
this noise:
•

While recording neuronal spikes, set the Low-cut filter to 100 Hz.

•

While recording cardiac signals (low-frequency), avoid using the "Filter Raw Data" module.
Instead, use "Filter Spike Data" so that the extracted beating signals (long spikes) are filtered.

Compute Measure Averages
•

Since this module is always at the end of the analysis chain, it can slow down the display of incoming data. Thus, it is not recommended to use this module during acquisition. When it is used during
acquisition:
•

Set the trace duration shorter than 10 minutes while the trace intervals for longer than the
trace duration.

•

Minimize the number of recording channels.

12

Mobius Tutorial (MED-A64MD1): Chapter 1-Introduction

1-4. Getting started

1-4. Getting started
When Mobius is opened, you will see blank diaplsy. The basic concept for the Mobius software is “you
need to create and run your own “Workflows” both for acquisition and analysis. You can create your Workflow by:
1. Building your own workflow using Mobius Editor.
2. Using the pre-defined workflow templates.
In this section, you will learn quickly:
1)
2)
3)
4)

How
How
How
How

to
to
to
to

use Mobius Editor to design your own workflow.
start data acquisition.
replay acquired data.
export raw data.

The following chapters will instruct you on how to start your experiments using some of workflow templates.

Figure 1-4.1. Basic concept for the Mobius software.
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1-4.1. Building up your own workflow using Mobius Editor
This section will quickly introduce you how to use Mobius Editor.
1.

Open Mobius. Select the [Workflow] > [New] > [Blank] to open
the “Mobius Editor” window.

Figure 1-4.2. Opening the Editor.
2.

This window shows a library of available task modules
(task specific panels) on its right panel. Click on a
module to see its description at the bottom of the
screen.
A workflow is created by building a list of task-specific
modules on the left panel of the Editor. When a module
is double-clicked, it is shifted to the left panel and the
task-panel for the module appears on the screen.
For acquisition, start by double clicking either the
[Acquire MED64R2 Data] or the [Acquire MED64R2
Data w/Stim] module. For replaying or analyzing the
acquired data, start with [Replay Raw Data File]. Other
modules for display and analysis can follow either of Figure 1-4.3. Mobius Editor.
these modules.
•

[Acquire MED64 Data] and [Acquire MED64 Data w/Stim] are acquisition modules for
SU-MED640 amplifier. It can NOT be selected for your amplifier (MED-A64MD1)

Figure 1-4.3 shows the designed acquisition workflow (top-left), its Editor (middle), and the workflow
structure (bottom).

Figure 1-4.4. An example of a designed acquisition workflow. The modules on the Workflow box (left box) are now on
the screen.
14
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3.

You will see arrows next to the modules on the left. Their meanings are described below;
•

Gray right pointing arrows: The modules with these arrows can be used AFTER the selected
module (highlighted in dark blue) in the Workflow list. Double-clicking a module with this
arrow next to it will insert it AFTER the selected module in the workflow.

•

Green right pointing arrows: The modules with these arrows are located AFTER the selected
module (highlighted in dark blue).

•

Light blue downward pointing arrows: The modules with these arrows can be used BEFORE the
selected module (highlighted in dark blue).

•

Gray downward pointing arrows: When these arrows appear next to a module name, they indicate that the output of this module can satisfy the input prerequisites of the currently selected
module (highlighted in dark blue) in the Workflow list. Double clicking one of these will insert
it BEFORE the selected step in the workflow.

•

Red steps: You may notice that some of module names are written in red text. This means that
the step does not meet input prerequisites. Select the red step (click on it once) to see which
modules can satisfy its needs (the ones with gray downward arrows next to them) and select
the appropriate one to add to the Workflow box (double-click them). Or, right-click the red
step and select [Delete] to remove this module from the Workflow box.

4.

In many cases, you can not have all the desired control panels on
a Tab (screen). You can create new tabs by selecting [Layout] >
[Add Tab], then type a name for the new Tab. (Figure 1-4.5)

5.

In order to have control panels on the new tab, 1) open the new
tab by clicking the tab name, and 2) open the Mobius editor and
edit modules on the new tab. You can go back and forth between
these tabs during your experiments.
Figure 1-4.5. Creating a new tab.
The Figure 1-4.6 shows analysis and export modules are added to
the workflow on a new Tab.

Mobius Tutorial (MED-A64MD1): Chapter 1-Introducion

15

1-4. Getting started

Acquire MED64R2 Data w/Stim
Display
All Channels

Export
Raw Data

Extract EP Measures

Compute Measure Averages

Save Measures Data

Main tab

Save Measure Averages

Analysis tab

Figure1-4.6. An example of a workflow design. A new tab (Analysis) is created, then analysis and saving modules are
added to this tab. The bottom chart shows the configuration of this workflow.
6.

Save it as your own Workflow. (Select [Workflow] > [Save as]). Now you are ready to for acquisition, and start acquisition by clinking the Green or Green-Red button.

7.

The Workflow can be opened by selecting [Workflow] > [Open].

Figure 1-4.7. Opening a workflow
16
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1-4.2. Data acquisition
Data acquisition is performed by running the acquisition workflow. Open your acquisition workflow by
selecting [Workflow] > [Open]. Data acquisition starts by clicking either of Green or Green-Red button
in acquisition workflow. For saving data:
1.
2.

Check the Enable storage check box, and then
Start acquisition with the Green-Red button.

Clicking the Green button starts acquisition WITHOUT saving data.

Figure 1-4.8. Checking the Enable storage.

Stop

Acquire WITHOUT
saving data

Acquire WITH
saving data

Pause

Figure 1-4.9. How the execution button works for acquisitions.
Mobius requires to save the acquisition workflow you made for saving the data file. Save your acquisition workflow if it is not made yet (See #6 in the page 14) in a folder. Acquisition with saving data
(clicking the Green-Red button) generates following files automatically at the same folder where the
acquisition workflow (.moflo) file is saved:
•
•
•

Data file (.modat)
Analysis workflow file(.moflo) including analysis modules you selected for your recording
Acquisition workflow file (.moflo)

Data file (.modat)
Acquisition workflow file (.moflo)
saved automatically
Analysis workflow file (.moflo)
saved automatically
Acquisition workflow file (.moflo)
you made
Figure 1-4.10. Data and Workflow files generated in a folder after acquisition (with GREEN-RED button).
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1-4.2. Opening and replaying acquired data
Acquired data (.modat file) can be opened with the [Replay Raw Data File] module. Analysis is performed in “analysis workflow” that contains this module. The quickest way to open the data file is using
the analysis workflow that was generated automatically when data was saved.
1.

Open an analysis workflow.

This Open menu is to open a workflow file (.moflo),
NOT data file (.modat)

Figure 1-4.11. Opening an analysis workflow.
2.

Click the box next to the Filename, and select the data file. When the file name appears on the Filename box (right in the Figure 1-4.12), the data is ready to be replayed.

Figure 1-4.12 Opening data file.
3.

Data is replayed when the Green button is clicked. (Clicking the Green-Red button activates saving/exporting enabled (See page 18)).

Stop

Replay data

Execute the
selected exporting

Pause

Figure 1-4.13. The way the execution buttons works for data replay and analysis.
18
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1-4.3. Starting with Workflow Templates
The easiest way to get started with Mobius is to use the predefined workflow templates. You can start
your experiments using these workflow templates right away or design your own workflow by editing
these templates. The following chapters will instruct you on how to start your experiment using these
workflow templates.

Noise_check
Basic_recording

Spontaneous_recording
Evoked_recording
Single_pulse_recording
Paired_pulse_recording

EP_recording

Theta_burst
LTD_conditioning

EPs

I-O_curve
EP_analysis

Single_pulse_analysis
Paired_pulse_analysis
Spike_recording

Spontaneous_recording

Spike_recording_cluster
Spike_recording_filter
Spike_recording_filter_cluster

Spikes
(New)

Spike_recording_stim
Spike_ recording_and_stimulation

Spike_recording_stim_cluster
Spike_recording_stim_filter_cluster
Spike_frequency_analysis

Spike_analysis

Spike_frequency_analysis_filter
Spike_sorting
Spike_sorting_filter
Beat_recording

Spontaneous_recording

QT_recording
Simple_recording

QT

Beat_frequency_analysis
Sponaneous_analysis

QT_analysis
Export_for_propagation_analysis_spontaneous

Pacing_recording
Pacing_analysis

Pacing_recording
Pacing_analysis

Figure 1-4-14. Available workflow templates.
1.

Click [Workflow] > [New] > [Templates]. Select either of [64MD1_1280x1024] or
[64MD_1920x1080] folder depending on the size of your display monitor, and then select desired
template.

2.

You can change parameters and save the template as your own workflow to go directly to your
experiment

3.

Or, modify the templates with Mobius Editor. Select [Workflow] > [Edit] to open the Mobius Editor.
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1-5. Exporting raw data
Raw data can be exported using Mobius [Export Raw Data] as either:
1)
2)
3)
4)

Binary shorts (2 byte integer values).
Binary doubles (8 byte floating point values).
ASCII text in “CSV” format.
Mobius native data format (.modat).

1.

Open an acquired data in analysis workflow including the [Export Raw Data].

2.

Check the “Enable storage” checkbox in the [Export Raw Data] module. (File name can be modified
in the Filename modifier box.)

3.

Select the data format.

4.

Select channels, Trace No, trace time for the Saving/Exporting in the [Replay Raw Data] module.
Channels shown with green will be enabled.

Figure 1-5.1. Exporting raw data. Raw data (waveforms) for channel 10 at 120000-125000 sec will be exported as an
“ASCII (text)” file in this example.
5.

After setting all parameters, save the analysis workflow as your own (Figure 1-5.2).

Figure 1-5.2. Saving the analysis workflow as your own.
6.

Run the analysis workflow with the Green-Red button. The exported data will be saved in the same
folder where the analysis workflow is saved.

20

Mobius Tutorial (MED-A64MD1): Chapter 1-Introduction

1-5. Exporting raw data

File Format Version
Session Start Time
time_ms
0
0.05
0.1
0.15
0.2
0.25
0.3
0.35
0.4
0.45
0.5
0.55
0.6
0.65
0.7
0.75
0.8
0.85
0.9
0.95
1
1.05
1.1
1.15
1.2
1.25
1.3
1.35
1.4
1.45
1.5
1.55
1.6
1.65
1.7
1.75
1.8
1.85
1.9
1.95
2

20071201
2012/11/10 05:10:19 +09
ch1_mV
-0.00162
-0.00077
-0.00253
-0.00633
-0.00534
-0.00352
-0.00316
-0.00274
0.000844
0.000211
0.001406
-0.00134
0.000352
0.000352
-0.00113
-0.00063
-0.00183
-0.00049
-0.00436
-0.00323
-0.00141
0.002531
0.005696
0.009704
0.007735
0.003305
0.001406
0.001617
-0.00478
-0.00429
-0.00499
-0.00963
-0.00394
-0.00211
-0.0012
-0.00352
-0.00429
-0.0038
0.003446
0.006329
0.00225

ch2_mV
-0.00689
-0.00288
-0.00323
-0.00394
-0.00499
-0.00577
-0.00534
-0.00218
-0.00127
-0.00162
-0.0019
-0.00338
-0.00239
0.001688
-0.00183
-0.00239
-0.00366
-0.00274
-0.00316
-0.00063
0.000563
-0.00098
0.002672
0.001336
-0.00478
-0.00563
-0.00563
-0.00253
-0.0019
0.002672
-0.00134
0.001336
0.00443
0.003094
0.003657
-0.00267
-0.00373
-0.00591
-0.00408
-0.00689
-0.00401

ch3_mV
-0.00598
-0.00654
-0.00534
-0.00281
-0.00401
-0.00401
-0.00457
-0.00563
-0.00506
0.000141
0.001336
-0.00443
-0.00429
-0.0019
-0.00211
0.000211
0.001406
0.004782
-0.00211
-0.00028
-0.00197
0.001547
0.000914
0.002531
0.00218
0.001899
0.000633
0.005344
0.001406
-0.00148
-0.00281
-0.00443
-0.00204
0.00218
0.005344
0.003868
-0.00084
0.001055
0.002672
-0.00246
-0.00288

ch4_mV
-0.00014
0.0045
0.005836
0.001828
-0.00288
0.004852
0.005555
0.0045
0.003516
0.006751
0.006891
0.004079
0.011181
0.009985
0.010829
0.00886
0.007102
0.005626
0.001266
0.002672
-0.00204
-0.0019
-0.00091
-0.00415
-0.00499
-0.0019
-0.00113
0.007454
0.003305
-0.00021
0.001406
-0.00218
0.001195
-0.00274
0.001406
-0.00218
-0.00584
-0.00984
-0.00373
-0.00471
-0.00731

ch5_mV
0.005626
0.008087
0.007243
0.003305
0.002321
-0.00415
-0.00288
0.001969
0.001195
0.002391
0.001617
-0.00436
-0.00795
-0.00309
-0.00316
-0.00014
-0.00541
-0.00345
-0.00563
-0.00408
-0.00028
0.002672
0.003305
0.001899
0.000563
0.000633
-0.00148
0.006751
0.004079
-0.00134
7.03E-05
0.000141
0.00436
0.001336
0.004922
0.006118
-0.00127
-0.00162
-0.00084
-0.00162
0.003164

ch6_mV
-0.0019
0.002672
0.001547
0.005415
-0.00091
-0.00415
-0.0057
-0.00274
0.003164
0.002742
0.003657
-0.00239
-0.00162
0.000141
-0.00049
-0.0019
0.000914
-0.00281
-0.00415
-0.00788
-0.00689
-0.00316
-0.00056
-0.0033
0.001899
-0.00077
-0.00148
0.004922
0.007313
-0.00169
0.000633
-0.00309
0.002813
-0.00134
0.001899
0.000492
0.004289
-0.00506
-0.00795
-0.00724
-0.00647

ch7_mV
-0.00021
-0.00225
-0.00288
0.001899
-0.00077
-0.00366
-0.0038
-0.00281
-0.00084
-0.00316
-0.00401
-0.00577
-0.00647
-0.00485
-0.00345
-0.00042
0.000422
-0.00091
-0.0026
-0.00105
-0.00155
-0.00197
-0.00197
0.001477
-0.00323
-0.00366
-0.00309
0.006118
0.003094
0.000492
-0.00028
7.03E-05
0.002461
-0.00197
0.003586
0.000281
0.00225
-0.00063
0.000141
-0.00169
-0.00345

Figure 1-5.3. example of raw data exported with ASCII displayed in Excel.
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Chapter 2

fEPSPs Recording

This chapter describes how to record and analyze fEPSPs using Mobius workflow templates. In this
chapter, you will learn about
1. Recording fEPSPs from hippocampal acute slices.
2. Long Term Potentiation (LTP).
3. Drug testing.
4. Replay and analysis of the acquired data.
5. Dat output.

2-1. Recording of fEPSPs

The goal of this section is that you be able to record fEPSP signals while measuring their amplitude and
slope using "Single_ pulse_recording” workflow template.

Opening the "Single_pulse_recording" workflow template.
1.
2.

Click [Workflow] > [New] >[From Template]. Select either of [64MD1_1280x1024] or
[64MD1_1920x1080] folder, depending on the size of your display monitor.
Select [EPs] > [EP_recording] folders. Select the “Single_pulse_recording” workflow template.

NOTICE:
In order to open the recording workflows, connect your PC to the MED64 amplifiers and turn on both
amplifiers.

Figure 2-1.1. Opening the workflow template.
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2-1.1. Overview of the “Single_ pulse_recording” workflow template
The "Single_ pulse_recording" workflow template consists of the following modules located in the
“Main” and “EPSP measures” Tabs.
Tab

Modules

Main

Acquire MED64R2 Data w/Stim / Dis play All Channels / Export Raw Data

EPSP m eas ures

Extract EP Meas ures (2) / Save Meaus res Data (2)

Evoked signals are acquired with the [Acquire MED64R2 Data w/Stim] module. The acquired signals are
sent to the [Extract EP Measures] module, where several types of amplitude, slope, and time are measured and graphed. Raw data can be exported to binary or ASCII ("CSV" formatted text file).The measurement chart can be saved as a "CSV" formatted text file.

“Main” Tab
“EPSP measures”
Tab

Figure 2-1.2. Module configuration for the “Single_pulse_recording” workflow template.
Acquire MED64R2 Data w/Stim

Export Raw Data

Save Measures Data

Display All Channels
Extract EP Measures

Figure 2-1.3. “Single_pulse_recording” workflow template. “Main” tab (left), “EPSP measures” tab (right).
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2-1.2. Overview of the [Acquire MED64R2 Data w/Stim] module
The acquisition and stimulation parameters are set in this module.
NOTICE:
Connect your PC to the MED64 amplifiers and turn on both amplifiers to open this module.

(9)

(11)

(10)
(1)

(4)

(5)

(2)

(6)

(7)

(8)

(3)

(12)
(12)
(13)
(14)

(15)
(16)
Figure 2-1.4. Top shows [Acquire MED64R2 Data w/Stim] module.
The bottom shows the stimulus parameters for the Step 2.

(17)

Acquisition
1.

# Traces: Number of Traces (Sweeps).

2.

Trace duration: Sampling (Recording) time for each
trace.

3.

Trace interval:
Interval between traces. (From the beginning of the first trace to the beginning of the next trace)

4.

Input Range (mV):
Maximum input signals level. This setting should be adjusted according to the signal amplitude to
achieve the maximal dynamic range. Select 2.3 mV, 2.9 mV, 5.0 mV, 12.5 mV, or 25 mV.
5 mV is recommended for recording of fEPSPs.

5.

Low cut freq (Hz):
High pass filter. Select 0.1 Hz, 1.0 Hz, 10 Hz, or 100 Hz. If 1.0 Hz is selected, signals with frequencies lower than 1 Hz are filtered out. Usually, 1.0 Hz is recommended for recording of fEPSP.

6.

Channels:
Select the channels for recording here. When the square box is clicked, the channel selector pops
up. The enabled recording channels are colored green.

7.

High cut freq (Hz):
Low pass filter. Select 1000 Hz, 2500 Hz, 5000 Hz, 7500 Hz, or 10000 Hz. If 5000Hz is selected,
signals with frequencies higher than 5000 Hz are filter out. Usually, 10000 Hz is good enough for
recording of fEPSP. Values lower than 2500 Hz is NOT recommended for recording of fEPSPs.

8.

Save raw data:
When Mobius is started by clicking the Green-Red recording button while the [Enable storage] is
checked, the raw data is saved. Enter a descriptive file name of your choice.
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Stimulation
Each Step is independent and can be programmed with different types of stimulation protocols. Enabled
steps will be applied in order (1 to 8) at the intervals set in the Trace Interval.
9.

“Enable step” check box:
When the box to the left of [Enable step] is checked, the Step becomes valid. The default settings
have Step1 and Step 2 enabled, and Steps 3-8 disabled (shown with # next to each Step). Step1
and Step 2 are applied alternately at 20 second intervals.

10. Stimulator selector and check box:
Select the MED64 amplifier’s built-in stimulator (F1 or F2) here. Checking the box on the right of
“Stim” activates the selected stimulator. The default settings have F1 enabled both for Step 1 and
Step 2. Stimulation is applied alternately at 20 second intervals.
F1 and F2 can be enabled at the same Step to stimulate 2 channels simultaneously.
11. Stimulus channel selector:
Select stimulus channel here. The stimulus channel can be changed either by the drop-down or the
pop-up which appears by clicking the square box. The green shows the stimulus channel.
Mobius needs to be stopped (with black button) or paused (with yellow button) for the stimulus
channel to be changed.
•

Stimulus channel can be changed without stopping or pausing by using the pop-up stimulus
channel selector. However, the changes are activated on the 2nd trace after the new channel is
selected by software since Mobius uses the next trace to reset itself.

12. Stimulus waveform editor:
Make your stimulus protocol here by selecting either [Const] or [Pulse] and typing in the desired
Length and Amplitude. Refer to Figure 2-1.5 for a schematic representation of a stimulus protocol
example.
•

Make sure that the STIMULUS CURRENT selection on the MED64 Head amplifier
(MED-A64HE1) is set to [NORMAL] to deliver the stimulus current amplitude set in Mobius.
Selecting [x2] doubles the output stimulus current amplitude set in Mobius.
(e.g. When 10 A is selected by Mobius with [x2] selected, the output stimulus current is 20
A. When -10 A is set in the Mobius with NORMAL selected, the output stimulus current
amplitude is 10 A)

•

The maximum stimulus amplitude set by Mobius is 100A. Set the STIMULUS CURRENT selector for x2 when stimulus amplitude with greater than 100 A is applied.

•

The maximum number of stimulus pulses to be programmed here at a Step is 21.

•

Do NOT select [Ramp] for the stimulation with the MED64. Only bi-phasic stimulation is recommended.
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-10A

pre stimulation time: 5 msec

0.2 ms

post stimulation time: 94.80 msec
c
Figure 2-1.5. Example of a stimulus protocol and itsschematic diagram.
13. Repeat pattern to trace end check box:
When this box is checked, the stimulus protocol programed at the Stimulus waveform editor (12)
will be repeated to the end of the trace. Useful for LTD conditioning.
14. Reps selector:
The stimulus protocol set at the “Stimulus waveform editor” (12) will be repeated the number of
times set here. Useful for multiple pulse stimulation such as LTP conditioning.
• Repeat of the stimulus waveforms which durations are longer than 1 minute is not recommended.
15. Stimulus current amplitude increment button:
When the + button is clicked, the absolute value of the stimulus current amplitude for the [Pulse] is
incremented by the value set it the left box. (16*) For example, if 2 is set in the box (16) and the +
button is clicked once, the stimulus amplitude will be changed to -12.00 A from -10.00 A. This is
useful for changing the stimulus amplitude for multiple pulse stimulations (e.g. Theta burst) with
just one click. The absolute value of the stimulus amplitude can be decreased sequentially using the
same procedure when - button is clicked.
•

The stimulus current amplitude can be changed even during recording by using this button.
However, the changes are activated on the 2nd trace after the change since Mobius uses the
next trace to reset itself.

16. See #15
17. Auto Inc check box:
When this box is checked, the stimulus current amplitude will automatically increase adding the
value (in A) set in the left box (16) to each preceding stimulation pulse. This is useful for making
I/O curves. Please refer to section 2-2.3.Input/Output curve (page 35) for details.
In the default setting, Step1 (F1) and Step 2(F1) run alternating every 20 seconds in this workflow.
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2-1.3. Running workflow
The workflow is run and stopped (paused) with the execution buttons.

Stop

Run WITHOUT
saving data

Run WITH
saving data

Pause

Figure 2-1.6. Execution buttons.

2-1.4. Before starting your experiment
When a recording workflow is run with Green or Green-Red button for the first time after it is opened
(or made), Mobius needs several seconds for its calibration (as seen in the pop-up message). Acquisition starts automatically after the calibration.
If you would like to start acquisition immediately after clicking the Green-Red button, run the workflow
with the green button for a few traces with both stimulators un-enabled, and then stop before starting
your experiment. When the workflow is run the next time, Mobius does not require calibration but
acquisition will start immediately.

Figure 2-1.7. The top shows pop-up mesage for the calibration. Acquisition
always starts after this message disappears.
In order to start recording immediately after clicking the Green-Red button,
run Mobius with the Green button for a few traces with stimulator un-enabled
before starting your experimen. (bottom figure.)
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2-1.5. Recording fEPSPs with single pulse stimulation
Now you will set the parameters for single pulse stimulation at a single channel and record fEPSPs.
1.

[Step1] and [Step2] are enabled in the "Single_pulse_recording" workflow template. Disable
[Step2] so that stimulation is applied only through the channel selected in the [Step1].
1)

Click the [Step2] tab and uncheck [Step enabled].

2)

You will see that the # mark appears next to [Step2], indicating that this Step is disabled.
(Refer to Figure 2-1.8)

1)

Figure 2-1.8. Disabling [Step2 ].
2.

Click on the tab for [Step1] so that parameters for the Step1 appear.
How do I change the stimulator at a given Step?
F1 is enabled for Step 1 in the default settings. Unless stimulation is applied through 2 channels
simultaneously, F1 can be used for all Steps. However, if you would like to use another stimulator (for
example, F2 instead of F1, change the stimulator following the procedure below:
1)

Uncheck [Stimulator Enabled] for F1 by clicking the check box.

2) Select F2 at the stimulator selector and check [Stim] for F2. Now F2 stimulator is enabled instead
of F1 (Figure 2-1.9)
•

Check both F1 and F2 to stimulate through 2 channels simultaneously.
Uncheck the F1 stimulator (left), then check
F2 stimulator (bottom)

Figure 2-1.9. Changing the stimulator to F2 from F1.
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3.

Make sure that the STIMULUS CURRENT selector on the MED-A64HE1 amplifier is set to [NORMAL].

•

Selecting of [x2] doubles the output stimulus current.
(e.g. when -10 A is selected in the Mobius with x2 selected, the output stimulus current is
-20 A.)

4.

5.

Start Mobius with the Green button (Run WITHOUT saving data). Find the best channel for stimulation by looking at the 64 channel display and changing the stimulation channel. You can also
change the amplitude during this procedure for optimal stimulation.
•

Mobius needs to be stopped or paused to change stimulus channels or/and amplitude.

•

The stimulus channels and/or amplitude can be changed without stop or pause by using the
“stimulus channel selector” and/or “the stimulus current amplitude increment button.” However, the changes are activated on the second traces after new channel/amplitude is set.
(Mobius uses the next trace to reset itself.)

When you find the optimal stimulation channel and amplitude, set the protocol for on-line analysis
as follows: (Refer to Figure 2-1.10)
1)

Open the "EPSP measures” tab.

2)

Set the [Step Filter] to Step1 for both measures.

3) Select the channels you want to monitor analysis on-line during your recording.
• Channels can be changed even during recording (or running) by scrolling or typing the numbers directly.

3)

2)

4)-(1) Click this button
to Edit measurements

Figure 2.1-10. fEPSP measurements.

30

Mobius Tutorial (MED-A64MD1): Chapter 2 - fEPSPs Recording

2-1. Recording of fEPSPs

4) The default settings have "Slope 1040 LinerFit” (red cursor) and "Amplitude Minimum” (blue
cursor) selected for measurement. Change the measurement menu if necessary. (Refer to Figure
2-1.11)
•
•

Mobius must be stopped to change the measurements.
Analysis can be done later off-line.
(1) Click [Edit Measures], and then select the measurement (analysis) you want at the [Measure
Type] column. (The name can be customized by typing it directly into the [Custom Name]
column.)
• Please click [Measures Help] for detailed explanations for the measurements.
(2) Click [Add Measures] to perform more analysis.
(3) To delete a measurement, right click the custom name and select the [Delete].
(4) Close this editor by clicking the [Hide] button.

(2)

(1)

(4)

(3)
Figure 2-1.11. Edit measurements.
5)
•

Set the cursors by clicking on them and dragging them to the desired position.
For detailed information on analysis, please refer to section2-4.3. Analysis of fEPSP signals on
page 45.

How do I adjust the graph scale to zoom in on the waveforms?
1) Left-clicking and dragging while pressing the shift button.
2) Changing the maximum (and/or minimum) numbers for both X (time) and Y (amplitude) axis.
Click, then, type in the new value(s) for the maximum and/or minimum.
•

6.

Double-clicking anywhere on the chart to return to the original axis range.

Make sure that [Enable storage] is checked in the [Save Raw Data] (“Main” tab) to save the data.
(The file name can be modified.) Set the # of traces.
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Figure 2-1.12. Workflow for single pulse recording stimulating at 1 channel. Only the F1 stimulator is enabled for
[Step1]. [Step2] is diabled.
bl d f [
] [
] d bl d
7.

Save this workflow as your Recording Workflow by clicking
[Workflow] > [Save As]. (Figure 2-1.13)

8.

Start Mobius with the GREEN-RED button.
•

Mobius will require you to save the workflow as your
own if you try to start Mobius with the Green-Red
button without having saved it already.

•

The data file (.modat file) and analysis workflow
including all analysis modules selected for the
recording workflow (.moflo file) and [Replay Raw
Data] module will be saved in the same folder.

Figure 2-1.13.

(Refer to Figure 1-4.10 on page 17 for files generated after recording.)
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2-2. Long Term Potentiation (LTP)
This section describes how to perform an LTP experiment. This method involves recording baseline
activity and LTP with one workflow, whereas conditioning stimuli is applied with another. The following
procedures are detailed in this chapter.
1.
2.
3.
4.
5.

Selecting the stimulation channels for experimental and control pathways.
Identifying the appropriate stimulus current amplitude for both pathways with an I/O curve.
Making the LTP workflow.
Making Theta burst workflow.
Recording LTP.

1. Selecting the stimulation channels
Open the "Single_pulse_recording" workflow template. Determine the 2 different stimulation channels
for experimental pathway and control pathways, and the desired channel for on-line monitoring by running the workflow without recording using the Green button. (Please refer to section 2-1.5. Recording
of fEPSPs” on pages 29-32)

2. Input/Output (I/O) curve
This procedure is carried out to determine the appropriate stimulus current amplitude for recording fEPSPs. The slope or/and amplitude are usually selected as the output parameters. A current amplitude
eliciting 30% to 50% of the maximal amplitude is typically selected. For LTP recording, the appropriate
stimulus amplitudes need to be identified with I/O curves for the control and experimental pathways.
1.

Open the “IO_curve” workflow template. In the default setting, (1)-10 A is selected for the initial
stimulus current amplitude, (2) the [Auto Inc] button is checked, and (3)5A is set for the increment value. The current amplitude will increase automatically by 5 A in subsequent trace until the
end of the recording (e.g. 10, 15, 20------. 105 A).
Modify the stimulus current amplitude, length, and increments depending on your signals and slice
viability. Change the stimulus channel to that identified for experimental pathway (or control pathway).

Figure 2-2.1. ”IO_curve” workflow template.
2.

(3)

(2)

(1)

Open the “EPSP measures” tab. Change the measurement to analyze if necessary, and then set the
cursors. (Refer to section 2-4.3. Analysis of fEPSP signals on page 45) Change the channels to
those you selected for on-line monitoring.
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3.

Save the workflow as your custom I/O curve workflow. Click the Green-Red button to start the
recording. (Click on the Green button if you would not like to save data).

4.

Determine the 30% (or 50%) for the maximal (saturating) stimulus amplitude. The following example shows a protocol in which the stimulation started at 5 A, and then increased by 5 A in every
subsequent trace. The responses saturated at the 12th trace (60 A) at approximately -1900 V.
The 30% and 50% of -1,900 V are 633 V and 950 V respectively. The stimulus current amplitude eliciting 30% of the maximal response is 20 A and the stimulus current amplitude eliciting
50% of the maximal response is 25 A.
5 A

10 A

20 A

25 A

60 A

30%, -633V
50%, -950V

Saturation
-1900V
Figure 2-2.2. Determination of the stimulus current amplitude eliciting 30% and 50% of the maximal response.
5.

Determine the stimulus amplitude for the experimental and control pathways.
• You can do test both pathways simultaneously if Step2 is enabled. In this case, stimulus amplitude increases by 5 A independently for each Step.

6.

After you identify the stimulus current for both pathways, close this workflow.

3. Making an LTP workflow
In this section, you will learn how to make your LTP workflow using the "Single_pulse_recording" workflow template. Both baseline and LTP will be recorded with this workflow. After recording of the baseline, you will apply theta burst with another workflow, and then come back to this LTP workflow for LTP
recording.
1.

Open the "Single_pulse_recording" workflow template, and modify the experimental parameters.
Keep in mind the following important points:
1)

# of traces: set the number so that both the Baseline and LTP recordings will run with this
workflow. For example, inputting 300 for the # of traces and 20 seconds for the trace interval will
result in a recording 100 minutes long (20 sec x 300 times).

2) Step 1 stimulation: change the stimulus channel to that selected for the experimental pathway,
and amplitude to that identified by the I/O curve for the experimental pathway. In Figure 2-2.3,
the stimulus amplitude was changed to -20 A and stimulus channel was changed to 30ch.
• Make sure that F2 stimulator is NOT enabled in Step1.
3)

34

Step 2 stimulation: change the stimulus channel to that selected for the control pathway, and
amplitude to that identified by the I/O curve for the control pathway. In the example, the stimulus
amplitude was changed to -25 A and stimulus channel was changed to 32ch. Make sure that F2
stimulator is NOT enabled in Step 2.
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4)
•

Make sure Steps 3-8 are NOT enabled.
In this example, Step1 is selected for the experimental pathway through which the theta burst
will be applied after recording of the baseline. Step2 is selected for the control pathway.

2)

1)

3)

Figure 2-2.3. Recording parameters for LTP recording.
2.

Open the EPSP measures tab and modify the analysis parameters.
1) Change the channel to that identified for on-line monitoring in the previous step.
2) Change the measurements (analysis) as necessary.
• The default settings enable Slope1040 Liner Fit and Amplitude Minimum.
3) Run a few traces with the Green button. Once waveforms appear, set the cursors for the
measurements.
•

Refer to section 2-4.5. Analysis of fEPSP signals on page 45 for detail.

Step1:
Experimental Pathway
(Conditioning stimulus
will be applied)

Step 2:
Control Pathway

Figure 2-2.4. Running the LTP workflow.
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3.

Save it as your own LTP workflow (Click [Workflow] > [Save as], and type file name) and leave it
open.

Figure 2-2.4. Saving the LTP workflow.

4. Making a workflow for LTP conditioning stimulus (e.g. Theta burst)
In an LTP experiment, you will need to apply a conditioning stimulus such as a theta burst to the experimental pathway right after recording the baseline activity. The best way to do so is to have the 2 workflows, for baseline/LTP recording and conditioning stimulus, open and ready on your MED64 PC. In this
section, you will make a workflow for the theta burst stimulation using the workflow template.
1.

Open the “Theta_burst” workflow template.

2.

Change the stimulus amplitude at the [Pulse] to the value determined for the experimental pathway.
•

Use the +/- button to change the amplitude. For example, in order to change to -20 A from
-10 A, select 10 A (Figure 2-2.5, (1)), then click the + button once (Figure 2-2.5, (2))so
that amplitudes for all 4 "pulses" are changed to -20 A. If you directly type the number at the
[Pulse] boxes, you must type it in 4 times for all [Pulse] boxes.

3.

Change the stimulus channel to that determined for experimental pathway. (Same to that selected
for Step1 at your LTP workflow).

4.

Make sure steps 2-8 are NOT enabled

5.

Make sure F2 stimulator is NOT enabled at Step1.

6.

Save as your own Theta Burst workflow

3

2

(1)

(2) Use these buttons so that all numbers at Pulses are
increased (or decreased) at one time.

Figure 2-2.5. Example of a theta burst conditioning stimulus protocol.
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7.

Uncheck the Stim box for F1, and then run this workflow with the
GREEN button once, and then stop.
•

When a recording workflow is run for the first time, Mobius needs
several seconds for its calibration before it starts acquisition. This
prevent you from applying conditioning stimuli quickly.
It is recommended to run this workflow with the stimulator disabled (with the “Stim” check box unchecked, Figure 2-2.6) before
you start your experiment so that conditioning stimuli is applied
right after the baseline recording.

8.

Figure 2-2.6.
Disable the stimulator.

Check the Stim box for F1 so that the F1 stimulator is enabled again. Leave it open on your MED64
PC.

5. LTP experiment
Now you have 2 workflows (LTP workflow and Theta Burst workflow) open on your MED64 PC, and are
ready to start recording.
1.

Activate the LTP workflow by clicking the title bar on the LTP workflow. Make sure that [Enable storage] is checked. Make sure that the STIMULUS CURRENT selector on the MED-A64HE1 amplifier is
set for [NORMAL]. Start your experiment by clicking the GREEN-RED button.

2.

After you finish recording baseline activity, PAUSE the experiment with the YELLOW button.
DO NOT stop the recording with the Black button. The experiment will be stopped. Baseline and LTP
data can NOT be stored in the same data file.

3.

Quickly activate your theta burst workflow by clicking the title bar on the theta burst workflow.
Apply the theta burst by clicking the Green button once. (or Green-red button if you would like to
save this data.)

4.

When the theta burst stimulus protocol is finished, quickly go back to the LTP workflow and restart
your experiment by clicking the GREEN-RED button.

Figure 2-2.7. LTP experiment.
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2-3. Drug testing
Mobius' [Compute Measure Averages] module calculates averages and standard deviations for the measurements (waveform analysis) in all experimental phases. This is a useful tool for making a
dose-response curve or comparing the results from different phases during drug application. This section will show you how to make a dose-response curve using this module.
Since this module is at the end of the analysis chain, it can slow down the data processing and causes
Mobius to stop during your experiment if you perform these analyses online. Thus, it is recommended
not to use this module during recording unless you are very familiar with your experiment and preparations. All analyses introduced in this section can be performed later off-line.
One alternative is just making bars (phase-annotations) at the beginning of phases (e.g. drug1) without on-line analysis. The location of the phase bars are saved to the analysis workflow. To do this, skip
steps 1-3 and start with step 4.
1.

Open the "Single_pulse_recording" workflow template.

2.

Add modules [Compute Measure Averages] and [Save Measure Averages] to this workflow template.
1) Make a new tab. Click [Layout] > [Add Tab], then type in the name for the new tab. (Figure 2-3.1)
2)

Open the Editor in the new tab. (Click [Workflow] > [Edit]) (Figure 2-3.2)

Figure 2-3.1. Making a new tab.

Figure 2-3.2. Editor is opened in the new tab.

3) Click the [Extract EP Measures -step1-], on the
left "Workflow" box, and then double-click the
[Compute Measure Averages] on the right
Available task panels. (Figure 2-3.3).
You will see the [Compute Measure Averages]
module shift to the left box, under the [Extract
EP Measures -step1-] (Figure 2-3.4). The panel
for this module will appear in the new tab.

Figure 2-3.3.

Figure 2-3.4.
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4) Click the [Compute Measure Averages] module on the left “Workflow” box, then double-click the
[Save Measure Averages] on the right “Available task panels" so that the [Save Measure Averages]
module is shifted to the “Workflow” box under the [Compute Measure Averages].
Averages and standard deviations for the [Extract EP Measures -step1-] (top chart in the EPSP
measures tab) will be computed and displayed. If online analysis for the other [Extract EP
Measurement-step2-](bottom chart) is necessary, add the same modules under the [Extract EP
Measures -step2-].

Figure 2-3.5. Control panels for the [Compute Measure Averages] and [Save Measure Averages] modules (left)
and the modules in the completed new workflow (right).

3.

Open the [Extract EP Measures] module (in the EP measures tab), select measurements for analysis, and set the cursors (refer to section 2-4.5.Analysis of fEPSP signals on page 45).

4.

Save it as your own workflow.

5.

Run Mobius with the GREEN-RED button. The first phase (baseline) will start from time 0.
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6.

Pause Mobius with the YELLOW button
when the first phase or baseline recording
is completed. Click [Annotations] > [Add
New phase]. Type the name for the 2nd
phase. (e.g. dose 1, Figure 2-3.6)
Do NOT stop with the Black button. If it is
stopped, the experiment will end and new
phases will NOT be added.

7.

8.

When the OK button is clicked, a yellow
bar with the chosen name appears on the
measurement chart. (Figure 2-3.7)

Figure 2-3.6. Making a new phase.

Re-start Mobius by clicking the
GREEN-RED button.
Time in the measurement chart will
continue running even during the pause.

9.

Pause Mobius with the YELLOW button
when the second phase (e.g. dose 1) is
completed. Click [Annotations] > [Add
New Phase] again.

Figure 2-3.7. Adding a new phase.

10. Type in the name for the 3rd phase. (e.g. dose 2) When the OK button is clicked, the yellow bar
with the name appears on the measurement chart.
11. Start Mobius again with the GREEN-RED button. Add subsequent phases using the same procedure.
12. You can see the table and graph of averages for each phase on the [Compute Measure averages]
module (in the “Averages” tab) (Refer to Figure 2-3.8)
•
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The phase annotations (yellow bars) can be shifted by clicking and dragging during off-line
analysis. When data is replayed after the phase annotations are shifted, averages and standard deviations are computed again based on the new phase annotations location.
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Figure 2-3.8. [Extract EP Measures] module with phase bars (top) and [Compute Measure Averages]
module (bottom).

Input fields in the [Compute Measure Averages] module
1.

Channel: Selects the channel to be displayed. The selection cannot be changed during recording.

2.

Use last: If this box is checked, the selected (or typed) number of data points are used for computation. This is mostly for off-line analysis.

3.

Hide: You can hide the measurement which is checked from the chart.
Note: the chart can be zoomed up or down by clicking and changing numbers of the maximum and/or
minimum scale for both X and Y axis.
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2-4. Replay and analysis of acquired data
Mobius data files (.modat) are opened and replayed with the [Replay Raw Data File] module and analyzed using the [Extract EP measures] module. In order to run and analyze the acquired data, you need
to create and run an analysis workflow. The quickest way to replay and analyze the acquired fEPSP data
is using the “Single_pulse_analysis” workflow template (which will be introduced in this chapter).
The analysis workflow including the analysis and saving modules you selected for your recording and
[Replay Raw Data File] instead of [Acquire MED64 Data w/Stim] are automatically saved to the same
directory where your recording workflow is saved. (Refer to page 17) The other quick way is to use
those workflows. The analysis workflow is opened by clicking [Workflow] > [Open] and selecting the
workflow (.moflo) file.

2-4.1. Replaying acquired data
1.

Click [New] > [From Template]. Select either of [64MD1_1280x1024] or [64MD1_1920x1080]
depending on the size of your display monitor. Select [EPs] > [EP_analysis] folders, and then
“Single_pulse_analysis” workflow template.

Figure 2-4.1. Opening the analysis workflow template.

2.

Open the acquired data file (.modat) by clicking the box next to the [Filename] and selecting the
desired file. When the file appears on the Filename box, the data is ready to be replayed by clicking
the Green button or Green-Red button. (Figure 2-4.2)

3.

When the Green button is clicked, the acquired data is just replayed. Clicking the Green-Red button
executes the enabled Exports or Saves.
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2

Figure 2-4.2. Opening the data file: When the file name appears in the Filename box, it is ready to be replayed.

Figure 2-4.3. Replaying fEPSP data.

Input fields for the [Replay Raw Data File] module
1.

Traces: Selects the trace(s) for processing.

2.

Trace time: Selects the trace time for processing.

3.

Channels: Selects the channels for processing. Click the box next to the “Channels” to open the
channel selector. Channels in green will be enabled.

4.

Delay: Set this value to a value greater than zero to insert a delay between data "blocks" sent out
by this module. It is useful for slowing down data processing.
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2-4.2. Overview of the “Single_ pulse_analysis” workflow template

The "Single_pulse_analysis" workflow template consists of following modules. (located in the 3 Tabs).

Tab

Modules

Main

Replay Raw Data File/ Display All Channels / Export Raw Data

EPSP measures
Averages

Extract EP Measures (2) / Save Meausres Data (2)
Compute Measure Averages (2) / Save Measuure Averages (2)

In general, the replayed data is sent to the [Extract EP Measures] module, where evoked signals are
extracted and their amplitude, slope, area, and time are measured and graphed. Phase measurement
averages are computed and graphed accordingly when phase annotations are added. The raw data can
be exported in either binary or ASCII ("CSV" -comma separated values- text file). The measurements
and averages chart can be saved by "CSV" formatted text file.

Replay Raw Data File
“Main” Tab
Display
All Channels

Export
Raw Data

“EPSP measures”
Tab

Extract EP Measures
Save
Measures Data

Compute
Measure Averages

Save
Measure Averages

Extract EP Measures
Save
Measures Data

Compute
Measure Averages

Save
Measure Averages

Figure 2-4.4. Module configuration for the “Single_pulse_analysis” workflow template.
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2-4.3. Analysis of fEPSP signals
Amplitude, slope, area, and time of the extracted waveforms are measured (analyzed) in the [Extract
EP measures] module. The extracted evoked potential waveforms are displayed at the left-most chart
and time course of the selected measurements are graphed on the right charts.

1). Raw Data Chart

3) Measurement Chart

3) Measurement Chart

2) Input fields
1

2

3

4

5

6

7

8

9

Figure 2-4.5. Extract EP Measures module.

1)
1.

Raw data chart
The raw data chart on the left most shows the extracted evoked responses waveforms. When a
measurement chart is clicked, the corresponding cursor appears on the raw data chart. The cursors
for the measurements are shifted by left-clicking and dragging.
2. You can zoom in on the raw data chart by
1)

left-clicking and dragging while pressing the shift button.

2) changing the maximum (and/or minimum) numbers for both X
(time) and Y (amplitude) axes. Click, then, type in the new
value(s) for the maximum and/or minimum. (Figure 2-4.6)
* Double-clicking anywhere on the chart to return to the original
axis range.
Figure 2-4.6.
3.

The cursor locations can be copied to all or specific channels by right-clicking and selecting the
[Apply Cursors to All Channels] or [Copy Cursors]. Select [Apply Cursors to All Measures] to
copy the cursor locations to all measures. (Figure
2-4.7)
Selecting [Copy Data] allows you to copy the
waveform data to an excel work sheet.

Figure 2-4.7.
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2) Input fields
1.

Channel No:
Selects the channel(s) for display by scrolling or typing
the numbers directly. These can be changed even during
recording or replaying.
When the channel selector is right-clicked and [Select] is
clicked, the Channel selector box appears. The channels
of interest are selected here as well. (Figure 2-4.8) This is
useful for running the 4-sample system by allowing users
Figure 2-4.8.
to save charts to 4 different CSV files.

2.

Step Filter:
Selects the Step to be analyzed here. Step1 is selected for the top chart and Step 2 is selected for
the bottom in the default settings. Useful for analyzing acquired LTP data with the “Single_
pulse_recording” workflow template.
•

In order to analyze Conductor data, ALL must be selected.

3.

Shift (ms):
For analysis of paired pulse experiments. When a number greater than 0 is selected here, the cursors and chart for the 2nd pulse appear.

4.

X Labels:
When this check box is clicked, the time point at which the waveform crosses the cursor is displayed on the Raw data chart.

5.

Reset: Resets the shifted cursors to the original positions.

6.

Hide phases:
The phase bar (yellow bars with characters on the measurement chart) is hidden when this button
is clicked. Please refer to the "Computing averages for phases" on page 48 for details.

7.

Autoscale:
When this check-box is checked, the scale for the measurement chart is automatically adjusted.
You can zoom in and out in the measurement chart by typing the number directly in the maximal
values for both the X and Y axes when the Autoscale button is NOT checked.

8.

Average:
When this box is checked, the averaged measurements are computed and graphed. Set the number
of traces to be averaged with the selector right to the check box. (e.g. if 2 is input and the box is
checked, every two traces (1st and 2nd, 2nd and 3d, 3rd and 4th.) are averaged and graphed.)

9.

Edit Measures: Click this button to select or change the measurement menu.
1)

Select the analysis (measurements) you desire from the [Measure Type] box to change the
default measures.

2)

You can name the selected measures by double-clicking and typing directly into the [Custom
Name] box.
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3) In order to have more measurements, click [Add Measures] button so another row on the table
and new measurement chart appear.
4)

You can delete unnecessary measurements by right-clicking the custom name, and selecting
the [Delete]. (Bottom figure in the Figure 2-4.9)
• Click [Measures Help] button for detailed information on measurements.

5) Click the [Hide] button to close this editor.

3)
2)
1)

4)
Figure 2-4.9.

3) Measurement chart
The time course for the selected measurements (analysis) are graphed here. Zoom in or out by changing the maximum (and/or minimum) values for the X and/or Y axis. Click and type the new number
directly.
Right clicking anywhere in the chart
and selecting [Copy Data] allows you
to copy the measurement data (only
for currently selected channel) into
an excel file. (Figure 2-4.10)
Selecting [Capture Image] allows
you to copy the chart image.

Slope1040LinearFit(uV/ms)
-265.604
-277.293
-285.283
-273.298
-280.4
-265.16
-268.563
Figure 2-4.10. Copying measurement data.

Measurement chart output
After you select the analysis parameters, you probably will want to output a measurement chart. When
the check box for [Save Measures Data] is checked and the analysis workflow is run with the Green-Red
button, the charts are saved as a "CSV" text file.
The “Single_pulse_analysis” workflow template is designed so that the charts for Step1 and Step2 are
exported as separate file in the default setting.
Please refer to section 2-4.5 Data output (pages 50-52) for detail.
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2-4.4. Computing averages according to phases
Mobius’ [Compute Measure Averages] module calculates averages and standard deviations for the
selected measurements (analysis) according to phases, and graph. This is useful for making a
dose-response-curve or comparing the measurements between phases such as baseline and LTP.
The “Single_pulse_analysis” workflow template includes the [Compute Measure Averages] module. This
section will show you how to make a dose-response curve by using this module in the workflow template.
If you would like to add this module to your own analysis workflow, please refer to the step1-2 at the
section 3-2. Drug testing on page 38.
1.

Open the [Extract EP Measures] module and replay the data by clicking on the Green button. The
first phase (baseline) will start from 0.

2.

When the first phase (baseline) is finished, Pause Mobius with the YELLOW
button. Click [Annotations] > [Add New
phase]. (Figure 2-4.11)

3.

Type in the name for the 2nd phase. (e.g.
dose 1). When the OK button is clicked,
the yellow bar with its name appears on
the measurement chart in the [Extract EP
Measures] module. (Figure 2-4.12)
NOTICE: If Mobius is stopped with the
Black button, replaying is terminated and
a phase bar can not be added.

4.

Start Mobius with the Green button again.

5.

Pause Mobius with the YELLOW button
when the second phase (e.g. dose 1) is
finished. Click [Annotations] > [Add New
phase] again.

6.

Type the name for the 3rd phase (e.g.
dose 2). When the OK button is clicked,
the yellow bar for the 3rd phase with its
name appears on the measurement chart.

Figure 2-4.11.

Figure 2-4.12.

7.

Restart Mobius with the Green button. Add subsequent phases with same procedure and replay the
data to the end.

8.

You will see the values and graphs for each phase in the [Compute Measure Averages] module.
(Figure 2-4.13, bottom)

9.

The phase annotations (yellow bars) can be shifted by left-clicking and dragging. When the data is
replayed after the phase annotations are shifted, averages and standard deviations are recalculated
based on the new phase annotation locations.

10. If you are satisfied with the location of the phase bars, save it as your own analysis workflow.
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11. In order to save the average chart to a "CSV" file, check the check-box for the [Save Measures
Averages] module, then run Mobius with the Green-Red button.

Figure 2-4.13. [Extract EP Measures] module with phase bars (top), and the table and charts at the [Compute Measure Averages] module (bottom).

Input fields for [Compute Measure Averages] module
1.

Channel: Selects the channel to be displayed. The selection can not be changed during replaying.

2.

Use last: When this box is checked, the selected (or typed) number of data points are used for
computation. For example, if 10 is selected, average and standard deviation are measured for the
last 10 data points in each phase.

3.

Hide: hides the measurement checked in the chart.
•

Note: the chart can be zoomed up or down by clicking and changing numbers of the maximum
and/or minimum scale(s) for both X and/or Y axis.
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2-5. Data output

Mobius allows you to output folowing data/analysis of fEPSPs signals:
1.
2.
3.

Raw data (waveforms)
Measurement chart
Average chart

All outputs are executed when Mobius is run by clickikng the Green-Red button with the check boxes for
the Save or/and Export modules are checked. (The analysis workflow needs to be saved to execute the
output.) Channels for output can be selected with channel selector in the [Replay Raw Data File] module.

Figure 2-5.1. The [Replay raw Data File] ready for expoert. Data for trace No 1-10 for channel 29 will be output

2-5.1. Export raw data
Please refer to 1-5. Exporting raw data (page 20-21) to export raw data.
Data for a waveform displayed in the [Extract EP Measurement] can be quickly copied to Excel with following procedure:
1.
2.
3.
4.

Select the waveform you would like to save in the [Extract EP Measurement]
Click anywhere in the Trace chart.
Select [Copy Data]
Open a new file in the excel, and then paste the data.

50

Mobius Tutorial (MED-A64MD1): Chapter 2 - fEPSPs Recording

2-5. Data output

Figure 2-5.2. Copying the waveform data to excel. Waveform data for Trace 28, ch 29 was copied to excel.

2-5.2. Save the measurement chart
Enable the [Save Measures Data] module. The measurements values are saved as a "CSV" formatted
text file.

File Format Version
Recording Date

STIMULATION PARADIGM 1
EPSP Slp (ms/uV)
Trace#
Step1-1
Step1-2
Step1-3
Step1-4
Step1-5
Step1-6
Step1-7
Step1-8
Step1-9
Step1-10
EPSP Amp (uV)
Trace#
Step1-1
Step1-2

20080210
2007/9/05 17:15:56 +09

Phase
Baseline

Time (s)

Phase
Baseline

Time (s)

0
40.219
80.422
120.625
160.813
201.016
241.219
281.422
321.625
361.813

0
40.219

ch1
ch2
ch3
-1.397
-2.041
-2.321
-1.011
-1.638
-2.49
-1.428
-2.305
-2.876
-1.06
-1.424
-2.953
-1.276
-1.552
-2.323
-1.116
-1.752
-2.665
-0.966
-1.614
-2.191
3.999
-1.436
-2.471
-0.948
-1.595
-2.415
-0.962
-1.716
-2.815

ch1
ch2
ch3
-8.545
-6.104
-7.324
-6.104
-7.324
-8.545

Figure 2-5.3. [Save Measure Data] module/control pannel (left) and example of the measurment chart saved as an
Excel compatible CSV file (right). The chart of slope linerfit and minimum amplitude for Step 1 are saved.
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2-5.3. Save the average chart
Enable the [Save Measure Averages] module. The values for the averages and standard deviations are
saved as a "CSV" formatted text file.
File Format Version:
Recording Date:

20090613
2007/7/13 06:44:04 +09

Slope1040LinearFit(uV/ms)
Phase
Baseline
dose 1
dose2
dose 3

ch1
+/-sd
ch2
+/-sd
ch3
32.528
5.996
-10.402
50.352
-63.225
32.239
9.716
-28.377
55.214
-61.097
39.948
11.97
-63.761
39.029
-62.029
48.442
5.472
-78.628
1.577
-65.594

EPSP Amp (uV)
Phase
Baseline
dose 1

ch1
+/-sd
ch2
+/-sd
ch3
-60.092
3.841 -246.416
5.54 -264.615
-59.937
5.853 -250.977
6.666
-260.01

Figure 2-5.4. [Save Measure Averages] module/control pannel (left) and example of the measurment chart saved as
an Excel compatible CSV file (right).
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Chapter 3

Spike Sorter

This chapter will teach you how to record and analyze spontaneous neuronal spikes (single unit activities) either from neuron cultures or brain slices using available workflow templates. In this chapter you
will learn:
1.
2.
3.
4.

How
How
How
How

to
to
to
to

record spontaneous neuronal spikes (single unit activities).
test drug effects.
replay and analyze spontaneous neuron spikes (single unit activities).
export analyzed data.

3-1. Recording spontaneous neuronal spikes (single unit
activities)
There are 5 workflow templates available for recording spontaneous neuronal spikes (single unit):
1.
2.
3.
4.
5.

Spike_recording (Recording with extracting spikes and their frequency analysis).
Spike_recording_filter (1 + filter).
Spike_recording_cluster (Recording with extracting, clustering spikes, and their frequency analyses).
Spike_recording_filter_cluster (2+filter).
Spontaneous_recording (Recording WITHOUT any real-time analysis).

Opening the workflow template
1.

Click [Workflow] > [New] > [From Template]. (Figure 3-1.1)

2.

Select either of [64MD1_1280x1024] or [64MD1_1920x1080] folder, depending on the size of your
display monitor. Select [Spikes] > [New] >[Spontaneous_recording] folders. Select the workflow
template.
•
•

Go to [Basic_recording] folder for the “Spontaneous_recording” workflow template.
Workflow for the old spike sorter modules are located in the [Archives] folder.

NOTICE:
Connect your PC to the MED64 amplifiers and turn on both amplifiers to open the acquisition workflows.
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Figure 3-1.1. Opening the workflow template.

3-1.1. Setting the acquisition parameters
All the acquisition workflow templates include the [Acquire MED64R2 Data] module. Acquisition parameters are set in this module.
NOTICE:
Connect your PC to the MED64 amplifiers and turn on both amplifiers to open this module.
(5)

(2)

(6)

(1)

(8)
(3)
(7)

(4)

(9)
Figure 3-1.2. [Acquire MED64R2 Data] module.
1.

#Traces: Number of Traces (sweeps).

2.

Auto Pause:
Mobius will pause automatically when the current trace is finished if the box is checked. The trace
interval set below becomes invalid when this box is checked. Mobius re-starts by clicking either of
Green button or Green-Red button.

3.

Trace duration: Sampling (Recording) time for each trace.

4.

Trace interval:
Interval between traces. (from the beginning of the first trace to the beginning of the next trace.)
•
•

In the default setting, signals are recorded for 5 minutes every 30 minutes (as seen in the following figure), which is repeated 48 times. Mobius will run for 24 hours in total.
The trance interval becomes invalid when AutoPause is checked.
5 min.

5 min.

30 min.
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5.

Input Range (mV):
Maximum input signal level. This setting should be adjusted according to the signal amplitude to
achieve the maximal dynamic range. Select 2.3 mV, 2.9 mV, 5 mV, 12.5 mV, or 25 mV. Larger number
for the Input Range creates lower voltage resolution. 2.3 mV is usually good enough for recording
of neuronal spikes.

6.

Low cut freq (Hz):
High pass filter for the amplifier. Select 0.1 Hz, 1.0 Hz, 10 Hz or 100 Hz. If 1.0 Hz is set, the signals
with frequencies lower than 1 Hz are filtered out. 100 Hz is recommended for the recording of
neuronal spikes.

7.

Channels:
Select the channels for acquisition here. When the square box is clicked, the channel selector pops
up. The enabled recording channels are colored green.

8.

High cut freq (Hz):
Low pass filter for the amplifier. Select 1000 Hz, 2000 Hz, 2500 Hz, 5000 Hz, 7500 Hz, or 10000 Hz.
If 5000 Hz is selected, signals with frequencies higher than 5000 Hz are filtered out. 10000 Hz is
recommended for the recording of neuronal spikes.

9.

Save raw data:
When Mobius is started by clicking the Green-Red recording button while the [Enable storage] is
checked, the raw data is saved. The file name can be modified.

3-1.2. Execution buttons

Acquisition is initiated by running an acquisition workflow. Clicking the Green button runs the
acquisition workflow without saving data while clicking the Green-red button runs the acquisition
workflow while saving data to disc.

Stop

Run WITHOUT Run WITH
saving data
saving data

Pause

Figure 3-1.3. How the execution buttons work for acquisition.
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3-1.3. Before starting your experiment
When an acquisition workflow is run with Green or Green-Red button for the first time after it is opened
(or made), Mobius needs several seconds for the calibration (as seen in the pop-up message). Acquisition starts automatically after the calibration.
If you would like to start acquisition immediately after clicking the Green-Red button, run the workflow
with the Green button for several seconds, and then stop it before starting your experiment. When the
workflow is run for the next time, it will not require calibration and acquisition will start immediately.

Figure 3-1.4. The pop-up message for the calibration.
CAUTION:
•

Make sure that the hard drive has enough free space when you start a long-term recording.
Acquisition with all 64 channels for 1 hour creates a 9.216GB file.
(9.216GB is represented as 9,000,000KB, 8,739.06MB, or 8.58GB in the Windows.)

•

Avoid saving data to the drive where the OS is installed (usually C drive). Save it to a separate hard
drive in the following cases:
1) When trace duration is set to longer than 30 minutes.
2) When trace duration is set to longer than 5 minutes and # Traces is greater than 12.

•

Extracting and/or clustering spikes can slow down Mobius' data processing and appear to freeze
when it extracts more spikes than it can analyze. This most often happens when non-biological signals cross the spike extraction thresholds on all channels at once. (e.g. Unexpected noises cross the
thresholds or the baseline fluctuates due to vibration.)

•

It is recommended you start your new experiments WITHOUT spike extraction or clustering (using
the Spontaneous Recording template or disabling spike detection). Perform your experiments with
real-time analysis when you are familiar with your preparation and experiments. When recording is
done with extraction, clustering, and filtering, please follow the instructions in section 1-2. Important notice on pages 8-10.
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3-1.4. Recording with extracting spikes and their frequency analysis
-Using the “Spike_recording(_ filter)” template-

Overview of the “Spike_recording(_filter)” workflow templates
The “Spike_recording(_filter)” template consists of the following modules.

Tabs

Modules

Main

Acquire MED64R2 Data / Display All Channels / Export Raw Data

Extraction

Extract Spikes Advanced

Spike

Compute Spike Freqs / Save Spikes / Save Spike Freqs / Display Spike Measures

Filter*

Filter Raw Data (2) / Display Single Channel (2)

* “Filter” tab is NOT available with the “Spike_recording” workflow template.

Acquire MED64R2 Data

Display
All Channels

“Main” Tab
“Filter” Tab

Export
Raw Data

Display Single Channel

Filter Raw Data

“Extraction” Tab
“Spike” Tab

Filter Raw Data

Display Single Channel

Extract Spikes Advanced

Compute Spike Freqs

Save Spikes

Save Spike Freqs

Display Spike Measures

Figure 3-1.5. Module configuration for the “Spike_recording_filter” workflow template. The “Spike_recording” does
nos include modules in the “Filter” Tab.
Thresholds are set using the [Extract Spikes Advanced] module and spikes crossing the set thresholds
are extracted. Spike frequency of all extracted spikes is computed and graphed during acquisition. You
can monitor 1) spikes are extracted, 2) the extracted spikes’ waveforms, and 3) the spike frequency
chart.
2 sets of [Filter Raw Data] modules are added in the “Filter” Tab. Acquired data can be filtered with
selected filter menu before sent to the [Extract Spikes Advanced] module. In the “Filter” tab, the top
[Display Single Channel] module shows the original non-filtered data while the bottom module shows
filtered data. (Refer to the bottom figure on the Figure 3-1-7).
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Acquire MED64R2 Data Export Raw Data

Display All Channels

.

Extract Spikes Advanced
Figure 3-1.6. Control panel for the “Spike_recording_filter” workflow template. ”Main” tab (top), and “Extraction” tab
(bottom).
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Save Spikes

Compute Spike Freqs

Save Spike Freqs

Display Spike Measures
Filter Raw Data

Display Single Channel
(Raw data is displayed)

Display Single Channel
(Filtered data is displayed)
Figure 3-1.7. Control panel for the “Spike_recording_filter” workflow template. “Spike” tab (top) and “Filter” tab (bottom). The “Spike_recording” does not have the “Filter” tab.
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Recording spontaneous neuronal spikes with spike extracting and their frequency analysis
Extracting spikes can slow down data processing and Mobius can even freeze when it extracts more
spikes than it can process. Refer to CAUTION on the page 56. Please follow the instructions below to
avoid stopping during acquisition when this workflow template is used (or this module is used for acquisition.)

1.

•

Select 100Hz for the low-cut filter. (Accidental low-frequency noise might cause to stop
Mobius).

•

Avoid enabling any [Export] or [Save] modules when raw data is saved. Once raw data is
saved, all exporting can be performed post-acquisition.

•

Set the trace duration (recording time) to less than 10 minutes and the trace interval to longer
than “the trace duration x 2” so that the analysis can catch up with the acquisition during the
trace interval. Particularly, keep the trace duration short for long-term recording lasting days,
weeks, or months.

•

Decrease the number of recording channels.

Open the “Spike_recording(_filter)” workflow template. (Refer to page 53)
Change the acquisition parameters in the [Acquire MED64R2 Data].
(Refer to section 3-1.1. Setting acquisition parameters on page 54-55.)

2.

Start Mobius with the Green button and run the workflow template for a few minutes to see signals,
and then stop.

3.

Select the channels for recording. Click the box next to “Channel” in the [Acquire MED64R2 Data]
module to have channel selector.

4.

Select the channels for spike extraction in the chart of [Extract Spike Advanced]. (Analysis is not
monitored during acquisition for the channels that are un-checked although data is saved.)
•

A selection is applied to all channels easily by 1) right-clicking the check box and 2) selecting
[Apply to All].

Figure 3-1.8. Enabling/disenabling the spike extraction.
5.

Make sure that [Export Raw Data] is NOT checked (Un check the check-box).
•
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Once raw data is saved, this can be done later.
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6.

Set the analysis parameters.
1) Change the filter menu depending on the acquired signals.
(If the “Spike_recording” template is used, this is not necessary.)
2) Set the thresholds.
•

Refer to section 3-3.2 Analyzing the spike rate on pages 74-82 for detail.

3) Change the parameters for [Compute Spike Freqs].
4) Make sure [Save Spikes] and [Save Spike Freqs] are NOT enabled.
•
7.

Run Mobius with the Green button again, then make sure that the thresholds you set are OK.
•

8.

Thresholds can be changed during acquisition. But it is not recommended to do so.

Save as your own acquisition workflow. (Refer to page 16) The workflow will be saved as moflo.file.
•

9.

It is not recommended to enable these modules during acquisition. These can be done later
once raw data is saved.

The data file (.modat file) and the Analysis workflow (including all analysis modules and
parameters selected for the acquisition workflow and [Replay Raw Data File] module) will be
saved in the same folder. (Refer to pages 17)

Make sure that the Save raw data in the [Acquire MED64R2 Data] module is checked, then run your
workflow with the Green-Red button.
•

It is recommended to start acquisition without spike extraction when you are not familiar with
your experiments. It is strongly recommended to start recording WITHOUT extractions for long term recording over several days or weeks.

•

Mobius will require you to save the workflow as your own if you try to start Mobius with the
Green-Red button without having it already.
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Figure 3-1.9. Spike extraction (top) and spike frequency analysis (bottom).
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3-1.5. Recording with spike sorting
-Using the “Spike_recording(_filter)_ cluster template-

Overview of the “Spike_recording(_filter)_cluster” workflow templates
The “Spike_recording(_filter)_cluster” workflow template consists of following modules.
Tabs

Modules

Main

Acquire MED64R2 Data / Display All Channels / Export Raw Data

Extraction

Extract Spikes Advanced
Cluster Spikes / Compute Spike Freqs / Save Spikes / Save Spike Freqs / Display Spike
Measures
Filter Raw Data (2) / Display Single Channel (2)

Spike
Filter*

* ”Filter” Tab is NOT available with the “Spike_recording_cluster” workflow template.

Acquire MED64R2 Data

Display
All Channels

Export
Raw Data

“Main” Tab
Display Single Channel

Filter Raw Data

“Filter” Tab
“Extraction Tab
“Spike” Tab

Filter Raw Data

Display Single Channel

Extract Spikes Advanced

Cluster Spikes

Compute Spike Freqs

.

Save Spikes

Save Spike Freqs

Display Spike Measures

Figure 3-1.10. Module configuration for the “Spike_recording_cluster_filter” workflow template. The
“Spike_recording_cluster” does not include the modules in the “Filter” tab.
Thresholds are set at the [Extract Spikes Advanced Spikes] and spikes crossing over the thresholds are
extracted. The extracted spikes are sorted (clustered) based on the similarity of waveform shapes. The
spike frequencies of each spike cluster are computed and graphed. You can monitor 1) that spikes are
extracted, 2) different spike clusters’ waveforms grouped by clusters, and 3) cumulated spike frequencies of each spike clusters.
2 sets of [Filter Raw Data] modules are added in the “Filter” Tab. The acquired data can be filtered with
selected filter menu before sent to the [Extract Spikes Advanced] module. In the “Filter” tab, the top
[Display Single Channel] module shows the original non-filtered data while the bottom module shows
filtered data. (Refer to the bottom figure on the Figure 3-1-7).
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Cluster Spikes

Compute Spike Freqs
Save Spike Freqs

Save Spikes

Measures

Display Spike Measures
Figure 3-1.11. Control panels in the “Spikes” Tab for the “Spike_recording(_filter)_cluster” workflow template. The
“Main” and “Filter” tabs are same as “Spike_recording_ filter”(Refer to Figure 3-1.5).

Recording spontaneous activities with spike sorting
The purpose of clustering spikes is to identify and separate signals referred from multiple cells acquired
on a single channel (electrode) based on their waveforms similarities. The extracted spikes are treated
as vector inputs to define centroids (center of mass vector). However, the centroids can not be defined
unless “frozen” (ignoring any incoming spikes to alter centroids) and will change depending on the
incoming spikes. Thus, on-line spike clustering is limited to give you an idea how many different kinds
of spikes you have on each channel (electrode).
More importantly, clustering can slow down Mobius’ data processing and appear to stop it when the
analyzing can not keep up with data processing. Thus, it is recommended to:
1) Use this workflow template to get an idea of how many kinds of spikes you have before starting
acquisition.
2) Start acquisition without the spike extraction or sorting. It is strongly recommended to do so
when recording is performed for long term.
When on-line spike sorting (clustering) is performed, please follow the instructions below;
•
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Select 100Hz for the low-cut filter. (Accidental low-frequency noise might Mobius to stop.)
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•

Do NOT enable any [Export] or [Save] module when raw data is saved.
(Exporting can be done later off-line.)

•

Set the Trace duration (recording time) to less than 10 minutes and the Trace intervals for longer than the trace duration so that the analysis catches up with the acquisition during the
trace interval. Particularly, make the trace duration even shorter for long-term recording lasting days, weeks, or months.

•

Decrease the number of recording channels.

1.

Open the “Spike_recording(_filter)_cluster” workflow template. (Refer to page 53)
Start Mobius with the Green button and run the workflow template for a few minutes to see signals,
and then stop.

2.

Select the channels for recording. Click the box next to “Channel” in the [Acquire MED64R2 Data]
module to have channel selector.

3.

Select the channels for spikes’ extractions in the chart of [Extract Spike Advanced].
•
•

All analyses are not performed during the acquisition for the channels that are un-checked
although data is saved.
The selection is applied to all channels easily by 1) right-clicking the check box and 2) selecting [Apply to All].

Figure 3-1.12. Enabling/disenabling the spike extraction.
4.

Make sure that [Export Raw Data] is NOT checked (Uncheck the check-box).
•

5.

After raw data is saved, this can be done post acquisition.

Set the analysis parameters.
1) Change the filter menu depending on the acquired signals.
(If the “Spike_recording” template is used, this is not necessary.)
2) Set the thresholds.
• Refer to section 3-3.2 Analyzing the spike rate on pages 74-81 for detail.
3) Modify the parameters for clustering spikes (in the [Cluster Spikes] module).
• Refer to section 3-3.3 Spike Sorting (pages 83-87) for detail.
4) Make sure [Save Spikes] and [Save Spike Freqs] are NOT enabled.
•

It is not recommended to enable these modules during acquisition with extracting spikes.
These can be done post-acquisition once raw data is saved.
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6.

Run Mobius with the Green button. Make sure that the thresholds you set are OK.
•

7.

Save as your own acquisition workflow. (Refer to page 54) The workflow will be saved as moflo.file.
•

8.

Although thresholds can be changed during acquisition, it is not recommended to do so during
acquisition.

The data file (.modat file) and the Analysis workflow (including all analysis module selected for
the acquisition workflow and [Replay Raw Data File] module) will be saved in the same folder.
(Refer to page 17)

Make sure that the Save raw data in the [Acquire MED64R2 Data] module is checked, then run your
workflow with the Green-Red button.
•

It is recommended to start acquisition without spike extraction when you are not familiar with
your experiments. It is strongly recommended to start recording WITHOUT extractions during long term recording over several days or weeks.

•

Mobius will require you to save the workflow as your own if you try to start Mobius with the
Green-Red button without having it already.

Figure 3-1-13. Spike sorting.
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3-1.6. Recording without analysis
-Using “Spontaneous_recording” workflow template-

There is workflow template for “recording without any analysis” available in the [Basic_recording]
folder. The spike extractions can slow-down Mobius’ data processing and cause it to stop when it
extracts more spikes than it can analyze. It is recommended to record signals using this template until
you are familiar with your preparation and experiment. Analysis and exporting can be done post-acquisition.
The “Spontaneous_recording” workflow template consists of following modules located in the 2 Tabs of
“Main” and “Monitor”. Acquired signals are simply displayed at all 64 channels and an any selected
channel. The data can be exported to binary or ASCII (“CSV” formatted text file).

“Main” tab
“Monitor” tab

Figure 3-1.14. Module configuration for the “Spontaneous_recording” workflow template.

Acquire MED64R2 Data

Export Raw Data

Display Single Channel

Display All Channels
Figure 3-1.15. Control panels in the “Spontaneous_recording” workflow template.
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3-2. Drug testing
The [Compute Measure Averages] module calculates averages and standard deviations for the spike
frequencies for all the experiment’s phases. This is a useful tool for making a dose-response curves or
comparing phases before, during and after drug applications. This section will demonstrate how to
make a dose-response curve for spike frequencies using this module.
Since this module is at the end of the analysis chain, it can slow down the data processing and cause
Mobius to stop during your experiment if you perform these analyses during acquisition. So, it is recommended not to use this module during recording unless you are familiar with your preparations and
experiment. All analysis introduced in this section can be done post-acquisition.
An alternate solution to avoid stopping is to just set the phase-annotations (yellow bars) without the
[Compute Measure Averages], and then analyze later. (The location of the phase bars will be saved in
your analysis workflow.) To do this, skip following steps 1-2 and start with Step 3.
1.

Open the “Spike_recording(_filter)” (or any other) acquisition workflow.

2.

Add the [Compute Measure Averages] and [Save Measure Averages] to this workflow template.
1)

Make a new tab. Click [Layout] > [Add Tab], then type in the new tab’s name. (Figure 3-2.1).

2)

Open the Editor in the new tab. (Click [Workflow] > [Edit]) (Figure 3-2.2)

Figure 3-2.1 (left). Making a new tab.
Figure 3-2.2 (right). Opening the Editor in the new tab.

3) Click the [Compute Spike Freqs] in the left “Workflow” box, then double-click [Compute Measure
Averages] in the right “Available task panels”. (Figure 3-2.3, left)
You will see the [Compute Measure Averages] module shift to the left box, under the [Compute
Spike Freqs] module (Figure 3-2.3, right). The control panel for this module appears in the new
tab.

Figure 3-2.3. Adding the [Compute Measure Averages] to the workflow.
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4)

Click the [Compute Measure Averages] module in the left “Workflow box”, then double-click on
[Save Measure Averages] in the right “Available task panels” so that the [Save Measure
Averages] is moved to the “Workflow box”, under the [Compute Measure Averages] and the
control panel for this module appears in the [Average] tab.
Averages and standard deviations for the spike frequencies will be measured and graphed in the
[Compute Measure Averages] control panel.

Figure 3-2.4. Control panels for the [Compute Measure Averages] and [Save Measure Averages] modules (top-left)
and all modules in the completed new workflow (bottom-right).
3.

Set all acquisition and analysis parameters, and then start Mobius by clicking the Green button.
(Refer to page 54-55,77-80)

4.

When you are satisfied with the new thresholds settings and other analysis parameters, stop and
save it as your own workflow. (Refer to page 54)

5.

Run Mobius by clicking the Green-Red button. The first phase (baseline) will start from time 0.

6.

Pause Mobius by clicking YELLOW button when the first phase (baseline) is finished. Click [Annotations] > [Add New Phase]. Type in the name for the 2nd phase. (e.g. Drug 1.) (Figure 3-2.5).
Do NOT stop with the Black button. If it is stopped, the experiment will end and new phases will NOT
be added.
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Figure 3-2.5. Making a new phase.
7.

When OK button is clicked, the yellow bar with the chosen name appears in the [Display Spike Frequencies] chart. (Figure 3-2.6)

Figure 3-2.6. a new phase is added in the [Display Spike Frequencies].
8.

Re-start Mobius with the Green-Red button.
Time continues running while paused in the measurement charts.

9.

When the second phase (e.g. Drug 1) is finished, pause Mobius with the YELLOW button. Click on
[Annotations] > [Add New phase].

10. Type in the 3rd phase name (e.g. Drug 2). The yellow bar with the name appears in the spike frequency chart when the OK button is clicked.
11. Start Mobius again with the Green-Red button. Add subsequent phases following the same procedure and run Mobius until the end of experiment.
12. You can see the averaged values for each phase on the table and their graph in the [Compute Measure Averages] (in the “Averages” tab) (Refer to Fig. 3-2.7)
•

70

The phase annotations (yellow bars) can be shifted by left-click and dragging when the data is
analyzed later. Averages and standard deviations will be calculated based on the new phase
annotations when the data is replayed.
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Figure 3-2.7. Computed measure averages. [Display Spike Frequencies] module with phase bars (top) and [Compute
Measure Averages] module (bottom).
Input fields in the [Compute Measure Averages] module
1.

Channel: Selects the channel to be displayed. The selection can not be changed while running
workflow.

2.

Use last: When this box is checked, the selected (or typed) number of data points are used for
computations. This is mostly used for post-acquisition analysis (Refer to page 82).

3.

Hide: hides the measurement checked in the chart.
•

Note: the chart can be zoomed up or down by clicking and changing numbers of the maximum
and/or scale(s) for both X and Y axis.
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3-3. Replay and analysis of acquired data
The Mobius data files (.modat) are opened and replayed with the [Replay Raw Data File] module, and
analyzed using modules such as [Extract Spikes Advanced], [Cluster Spikes], and [Compute Spike
Freqs]. You will design your Analysis workflow by combining those modules for replay and analysis of
the acquired data. The quickest way to replay and analyze the spike data is using the Analysis workflow
template, which will be introduced in this chapter.
The Analysis workflow with the [Replay Raw Data File] and the analysis modules you selected for your
acquisition will be automatically saved to the same directory when you run acquisition workflow with
the Green-Red button. These analysis workflows can also be used for quickly performing analysis.

3-3.1. Opening and replaying acquired data
1.

Open the analysis workflow template. Click [New] > [From Template]. Select either of
[64MD1_1280x1024] or [64MD1_1920x1080] folder, depending on the size of your display monitor.
Select [New] > [Spikes] > [Spike_analysis] folders, then select an analysis workflow template.
Four templates are available for analyzing spontaneous neuron spikes (single unit activities).
1) “Spike_frequency_analysis”: Spikes are extracted and spike frequency is computed and
graphed.
2) ”Spike_frequency_analysis_filter”: 1) + filter
3) “Spike_sorting”: Spikes are extracted and sorted (clustered). Spike frequencies of clustered
spikes are computed and graphed.
4) “Spike_sorting_fiter”: 3) + filter

Figure 3-3.1. Opening analysis workflow template.
•
5.

In order to open your own analysis workflow, click [Workflow] > [Open], and then select the
workflow file (.moflo).

Open the data file by clicking the box next to the “Filename” and select the desired .modat file.
When the file name appears in the Filename box as seen on the right figure of the Figure 3-3.2, the
data is ready to be replayed by clicking the Green button or Green-Red button.
•
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Opening large data files can take several minutes. (e.g. Opening 10GB data takes over 1 minute.)
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6.

The acquired data is just replayed when the Green button is clicked. Clicking the Green-Red button
while checking the [Enable] check-box executes the selected Export or Saves.

Click here to
open a data file.

Figure 3-3.2. Opening a data file. When the file name appears in the Filename box, it is ready to be replayed.

Figure 3-3.3. Replaying spike data.
Input fields for the [Replay Raw Data File] module
1.

Traces: Sects the trace(s) for processing.

2.

Trace time: Selects the trace time for processing.

3.

Channels: Selects the channels for processing. Click the box next to the “Channels” to open the
channel selector. Channels in green will be enabled.

4.

Delay: Set this value to a value greater than zero to insert a delay between data “blocks” sent out
by this module. It is useful for slowing down data processing.
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3-3.2. Analyzing the spike frequency
This section describes how to analyze the spike rate with the “Spike_frequency_analysis_filter (or,
Spike_frequency_analysis)” workflow template. These Analysis templates consist of following modules
located in the Tabs of “Main”, “Extraction”, “Spike”, “Filter”, and “Averages”.

Tabs

Modules

Main
Extraction
Spike
Filter*
Averages

Replay Raw Data / Display All Channels / Export Raw Data
Extract Spikes Advanced
Compute Spike Freqs / Save Spikes / Save Spike Freqs / Display Spike Measures
Filter Raw Data (2) / Display Single Channel (2)
Compute Measure Averages / Save Measure Averages

* “Filter” tab is not available with the “Spike_friquency_analysis” workflow template.

The raw data is filtered by the selected filter menu. Thresholds are set and spikes crossing the
pre-defined thresholds are extracted in the [Extract Spike Advanced] module. Spike frequencies of all
extracted spikes are computed and graphed. Raw data can be exported as a binary or ASCII (“CSV” formatted text) file. Waveforms of extracted spikes, time stamp, and spike frequency charts can be saved
as “CSV” formatted text file.
The [Compute Measure Averages] module calculates and graphs the spike frequency averages for the
different phases. In the “Spike_frequency_analysis” template, the replayed data is sent to [Extract
Spikes] module without filtering.

“Main” tab
“Filter” tab
“Extraction” tab
“Spikes” tab
“Averages” tab

Figure 3-3.4. Module configuration for the “Spike_frequency_analysis_filter” workflow template.
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Replay Raw Data

Export Raw Data

Display All Channels

.

Extract Spikes Advanced

Figure 3-3.5. Control panel for the “Spike_frequency_analysis_filter” workflow template. ”Main” tab (top), and “Extraction” tab (bottom).
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Save Spikes

Compute Spike Freqs

Save Spike Freqs

Display Spike Measures
Filter Raw Data

Display Single Channel
(Raw data is displayed)

Display Single Channel
(Filtered data is displayed)
Figure 3-3.6. Control panels in the “Spike_frequency_analysis_filter” workflow template. “Spike” tab (top) and “Filter”
tab (bottom). The “Spike_frequency_analysis” does not have the “Filter” tab.
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Setting the filter menu
Raw data can be filtered using the [Filter Raw Data] module (in the Filter tab) before spikes are
extracted. Therefore, spikes are extracted from filtered data rather than raw data.
1.

Replay data by clicking the Green button to have signal in the Display Single Channel.

2.

The workflow template allows you to set 2 different types of filters. Select the type of filter in the
“Filter Type” drop down menu and the cut-off freqs (or time) scale in the bottom drop down menu
below.

3.

The top chart displays the raw data and the bottom chart displays the filtered data. The scale for
amplitude (Y axis) can be modified by clicking and typing directly in the maximum and /or minimum amplitude values (Figure 3-3.7).

4.

The time (X axis) can be changed by selecting numbers in the “Duration” drop down menu. The
maximum duration is 10 sec (Figure 3-3.7).

Change the duration
(Scale for X axis)
here

Figure 3-3.7. Setting the filter menu in the Filter tab. The top display shows the raw data and the bottom display shows
the filtered data.
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Setting the thresholds
Set the thresholds in the [Extract Spike Advanced] module (in the [Extraction] tab). The module has 4
options to set the thresholds:
1.
2.
3.
4.

Typing the values in the chart.
Moving the bars in the Trace chart.
Moving the bars in the 64ch display.
Setting the Standard Deviation (SD) percentage of signal amplitude.

Extracted spikes are highlighted with light-green at both single and all channels display.

Figure 3-3.8. [Extract Spikes Advanced] module. Thresholds are set in this module.
The top-left chart allows you to set the values for thresholds as well as pre/post times. Double-click and
type in new values directly to change them. A value can be applied to all other channels by right-clicking the number and selecting “Apply to ALL”. (Figure 3-3.9)

Figure 3-3.9. Changing the thresholds in the chart (left). The value can be applied to all channels at once (right).
The extractions are on or off using the “On” check box. The selection here is also applied to all channels
by right-clicking the check box and selecting “Apply to All”.
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•

Please refer to Mobius User Guide (5.2.4. Extract Spikes) for more information on thresholds
and pre/post times.

•

Channel limit selector: the maximum numbers of spikes to be extracted per 1 second per
channel is set here. This is useful for preventing Mobius crash due to unexpected high-frequency noise during acquisition.

Thresholds can be changed by clicking and dragging the red threshold bar both in the single
channel display or within the all channels display chart. Simply click the red bar, and the drag it to
desired location.
Thresholds can be set based on “RMS percentage of the baseline noise”. Select the value for percentage
and click the [Set thresholds] button.

Figure 3-3.10. Moving threshold bars (red). Click and drag them to desired location to set thresholds.

[Display Spike Measures] charts
The [Display Spike Measures] has 3 charts and show you the analysis in a selected channel. A channel
for displayed is selected in the channel selector in the bottom-left.
1) Trace 1 chart (top-left):
Spike extractions are displayed. Extracted spikes are high-lighted in light green color.
2) Extracted Spikes chart (top-right):
Extracted spikes’ waveforms are displayed.
3) Spike Frequency chart (bottom):
Time course of spike frequency are graphed here.
The duration of the display in the 1) and 2) can be changed in the “Duration” drop down menu (Figure
3-3.11). The time (X) and amplitude (Y) scale can be changed with by clicking the minimum and/or
maximum value and typing a new number (Figure 3-3.12). (Scales in the Spike Frequency Chart are
unchangeable.

Figure 3-3.11. [Left] Channel selector and Duration drop down menu.
Figure 3-3.12. [Right] Changing the scale for the Time (x) by clicking the maximum value and typing a new number
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Setting the parameters for computing spike frequency
Spike frequencies for all extracted spikes are computed with the [Compute Spike Freqs] module.
Mobius gives instantaneous spike frequency for each second at 1 second resolution. The default
setting has 1 second selected for the Binning window size. Extracted spikes are counted every 1 second. Selecting “Trace” instead of “Arbitrary (s)” means the spikes are counted for the whole trace.

Figure 3-3.13. [Compute Spike Freqs] control panel.

After setting all analysis parameters, you are now ready to output the data. Please refer to Data Output
(for page 86) for exporting the analysis.

Figure 3-3.14. Spikes extractions and their frequencies analysis.

NOTE:
The 3 charts in the [Display Spike Measures] are available as independent modules/control panels of
[Display Extracted Spikes (traces only)], [Display Extracted Spikes (waveforms only)], and [Display
Spike Frequencies] for more flexibility.
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3-3.3. Computing spike frequency averages according to phase
-Making the dose-response-curve-

The [Compute Measure Averages] module calculates spike frequency averages and standard deviations
for all experimental phases. This is a useful tool for making a dose-response curve. This section will
walk you through making a dose-response curve for spike frequency using the “Spike_
frequency_analysis(_filter)” workflow template in which this module is included.
If you would like to add this module to your own analysis workflow, please refer to the step1-2 at the
section 3-2. Drug testing on pages 66-67. (If you added phase bars while recording, the location of the
phase bars were saved to your analysis workflow.)
1.

Set the all analysis parameters according to the previous section 3-3.2 Analyzing the spike frequency (Pages 74-81).

2.

Open the “Spike” tab and replay data by clicking the Green button. The first phase (baseline) will
start from 0.
When the first phase is finished, pause Mobius with the YELLOW button. Click [Annotations] > [Add
New phase]. Type in the name for the 2nd phase. (Figure 3-3.15, left)
When the OK button is clicked, the yellow bar with its name appears on the Spike Frequency chart
(Figure 3-3.15, right).
NOTE:
If Mobius is stopped with the Black button, replaying is terminated and a phase bar can not be
added.

Figure 3-3.15. Adding a new phase bar (left) and the new phase bar added on the spike frequency chart (right).
3.

Start Mobius by clicking the Green button again. When the 2nd phase is finished, pause Mobius with
the YELLOW button and make a new phase.

4.

Replay the data to the end. Averages and standard deviations are computed and graphed for each
phase (dose) in the [Compute Measure Averages] module in the “Average” tab (Figure 3-3.16).

5.

The phase annotations (yellow bars) can be shifted by clicking and dragging. The averages and
standard deviations are recalculated once Mobius is run with the Green or Green-Red button after
changing the locations of phase bars.

6.

If you are satisfied with the location of the phase bar, save it as your own analysis workflow.
(Refer to page 54)
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7.

In order to save the average chart to a "CSV" file, check the check-box for the [Save Measures
Averages] module, then run Mobius with the GREEN-RED button.

Figure 3-3.16. [Display Spike Frequencies] module with phase annotation bars (top) and the graphs for averages and
standard deviations in the [Compute Measure Averages] (bottom).
Input fields for [Compute Measure Averages] module
1.

Channel: The channel to be displayed is selected here. Channels can NOT be changed during replay.

2.

Use last: When this box is checked, the selected (or typed) number of data points are used for
computations. For example, if 10 is selected, average and standard deviation are computed for the
last 10 traces in each phase.

3.

Hide: hides the measurement checked in the chart.
•
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Note: the chart can be zoomed up or down by clicking and changing numbers of the maximum
and/or minimum scale(s) for both X and/or Y axis.
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3-3.4. Spike sorting (clustering)
The purpose of sorting (clustering) spikes is to identity and separate signals referred from multiple cells
acquired on a single channel (electrode) based on their waveform similarity.
This section will teach you how to sort (cluster) spikes and analyze the spike frequency using the
“Spike_sorting(_filter)” workflow template. This template include following modules in the tabs of
“Main”, “Spike”, and “Filter”
Tabs

Modules

Main

Replay Raw Data / Display All Channels / Export Raw Data

Extraction

Extract Spikes Advanced
Cluster Spikes / Compute Spike Freqs / Save Spikes / Save Spike Freqs / Display Spike
Measures
Filter Raw Data (2) / Display Single Channel (2)

Spike
Filter*

The raw data is filtered by the selected filter menu. Thresholds are set and spikes that cross the predefined threshold are extracted in the [Extract Spike Advanced]. The extracted spikes are sorted
based on the waveform shape similarity. Clustered spike frequency is computed and graphed. Raw
data can be exported as binary or ASCII (“CSV” format text) file. Extracted spike waveforms, time
stamp, spike centroids and spike frequency charts can be saved as “CSV” format text file.
With the “Spike_sorting” workflow template, the replayed data is not filtered but sent directly to the
[Extract Spikes Advanced].

“Main” tab
“Filter” tab
“Extraction” tab
“Spikes” tab

Figure 3-3.17. Module configuration for the “Spike_sorting_filter” workflow template.
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Cluster spikes

Figure 3-3.18. “Spike_sorting_filter” workflow template. [Extraction] tab (top) and [Spikes] tab (bottom). Spikes are
color-coded at all display panels.
Set the filter menu and thresholds with the same procedure described in the page 77-81.
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Setting the menu for spike sorting (clustering)
As mentioned above, the purpose of sorting (clustering) spikes is to identify and separate signals
referred from multiple cells acquired on a single electrode based on their waveforms.
The sensitivity of the clustering process is changed using (1) Similarity Radius and (2) Min # spikes
parameters.
The default settings are 30% for the Similarity
Radius and 5 is for Min # spikes. This means:
when spikes with similar waveforms occurs 5
times, a valid cluster is identified and its centroid
(an “average” spike shape) is determined. Spikes
not assigned to any cluster are not color coded.
They will remain green until there are 5 spikes
with similar waveforms.

(1)
(2)

Extracted spikes that come sequentially are
assigned to a Cluster (A,B,C, etc.) if their similarity
to the Cluster’s centroid is higher than 30%.
Figure 3-3.19. Cluster Spikes module.
Spikes with less than 30% similarity to the Centroid will remain green. Un-assigned spikes will be marked as NC in the saved data.
Each Cluster (A,B,C, etc in the Mapping chart) has a different color code (e.g. A with red) and its waveforms and frequencies are displayed with the same color code on the charts in all display modules that
come under the [Cluster Spikes] module.
The Parameters to establish valid sets of clusters can be modified as followings:
(1) Similarity
This parameter determines how sensitive the sorting (clustering) is to variations in spike waveforms.
Larger numbers > more sensitive to spike shape variations > produce FEWER clusters.
Smaller numbers > less sensitive to spike shape variations > produce MORE clusters
(2) Min # spikes
This determines how many spikes need to come to be recognized as a Cluster.
Increasing this value means FEWER clusters.

After replaying data to determine centroids, you may see that different clusters (e.g. C and D) actually
represent the same cell and you may want to merge them. Change the Cell number for Cluster D to 3
by double-clicking and directly typing in this number so that the Cluster D is merged to the Cluster C
(Figure 3-3.20).

Figure 3-3.20. Merging Cluster D and C.
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For another example, you may see that Cluster E is probably just noise and you want to remove it from
your analysis. In this case, you can delete this cluster by deleting the number at the Cell column. (Right
click the Cell number, then select Delete.) (Figure 3-3.21)
Those changes can be reset by clicking [Reset Mapping] button.

Figure 3-3.21. Deleting a Cluster.
Once you have a valid set of Clusters that you believe represent different cells, you can freeze them by
checking the [Freeze centroids] check-box. This means that incoming spikes will NOT alter the definition of the existing clusters (their centroids), nor cause new clusters to form. Centroids must be frozen
to be definitely established. Otherwise, centroids are changing whenever new spike is assigned to a
cluster.
CAUTION:
Freeze Centroid to export all analysis data with accurate clustering.

Display of sorted spikes
Spikes’ extractions are displayed in the “Trace 1” chart while the waveforms for extracted spikes are
displayed in the “Extracted Spikes” chart in the [Display Spike Measures]. Be noted that extracted
spikes are color coded according to cluster since these modules are under [Cluster Spikes] in the
“Spike_sorting(_filter)” workflow template. Spikes NOT assigned to any Cluster are displayed in green.
In the “Extracted Spikes” chart, you will see waveforms with solid lines and ones with dot lines. The
waveforms with solid lines are the centroid waveforms and the dotted lines are extracts spikes’ waveforms (Figure 3-3.22). (Refer to page 79 for further information and modifications for these charts.)

Figure 3-3.22. “Extracted Spikes” chart in the “Spike_sorting_(filter)” template. Solid lines show centroid waveforms
while dot lines extracted spikes' waveforms.
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Computing spike frequencies for sorted spikes
In the “Spike_sorting(_filter)” workflow template, [Compute Spike Freqs] is under the [Cluster Spikes]
module. Spike frequencies are computed independently for clusters and color-coded in the [Display
Spike Frequencies] control panel.
Note that the frequency calculations are reset when a new cluster is formed during replay
(or acquisition). When the check box for [Freeze Centroids] is checked, the numbers of clusters are
fixed and frequency calculations are not reset anymore.
After replaying all data and modifying the clustering, check the [Freeze Centroids] to have the
spike frequencies analyzed properly.

Figure 3-3.23. Computing for spike frequencies of clustered spikes. The [Display Spike Frequencies] panel is reset
whenever a new cluster is formed.

Figure 3-3.24. Spike frequencies are now displayed properly with the Centroid frozen.
After setting all analysis parameters, you are now ready to output the data. Please refer to Data Output
(for page 88-91) for exporting analyzed data.
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3-4. Data Output

Now, you are ready to output your analyzed data. All analysis results can be saved as “CSV” formatted
text file with following procedures.
1.

Check the check-box for the [Save] module (e.g. Save Spikes, Save Spike Freqs), that you would
like to output the data (Refer to page 89-91). File names can be modified by directly typing them
into the Filename modifier box.

2.

Select channels, Trace No, trace time for the Saving/Exporting to export in the [Replay Raw Data]
module. Channels shown with green will be enabled. (Figure 3-4.1)

Figure 3-4.1. [The Replay Raw Data File] ready for export. Data for 300,000-600,000 msec at channel 36 will be
saved.
3.

After setting all parameters, save the analysis workflow as your own. (Figure 3-4.2)

Figure 3-4.2. Saving analysis workflow.
4.

Run the analysis workflow with the Green-Red button. The output data will be saved in the same
folder where the analysis workflow is saved.

NOTE:
In the “Spike_sorting(_filter) “ workflow template, all Save module is under [Cluster Spikes]. All saved
data include “Cluster ID”.
CAUTION:
The Centroids MUST be frozen for the all analyzed data saved correctly when clustered spikes are
exported.
Please refer to 1-5. Exporting raw data (page 20-21) for exporting raw data.
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3-4.1. Saving extracted spikes and time stamps
Check the “Enable storage” in the [Save Spikes], and then run the analysis workflow with the
Green-Red button to save the analysis below as a “CSV” formatted text file.
1) Time stamp only, or
2) Time Stamps, and waveforms of all extracted spikes

Figure 3-4.3. [Save Spikes] module/control panel. Time stamps and spikes waveforms will be saved.
Figure 3-4.5 is an example of the time stamps and waveforms for clustered spikes saved as a “CSV” file
displayed in Excel. Be noted that each Time Stamp and waveforms have cluster IDs since the
“Spike_sorting(_filter)” workflow template is used. If non-clustered spikes are exported (using
“Spike_frequency_analysis), the column for cluster_id has all NONE.

Session 2010/8/11 19:03:39 +09:00
Trace Du
10252

channel time_of_day
1
1
1
2
2
3
3
5
5
5
6
6
6
6
6
7
9
9
9
9
9

19:03:39.221
19:03:39.271
19:03:39.344
19:03:39.19
19:03:39.282
19:03:39.021
19:03:39.292
19:03:39.177
19:03:39.217
19:03:39.351
19:03:39.461
19:03:39.468
19:03:39.472
19:03:39.485
19:03:39.492
19:03:39.437
19:03:39.006
19:03:39.011
19:03:39.056
19:03:39.073
19:03:39.113

within_se
within_trac
within_session_ti
ssion_tim
e_time_ms
me
e_ms
0d:00:00:00.221
221.4
221.4
0d:00:00:00.271
271.25
271.25
0d:00:00:00.344
344.55
344.55
0d:00:00:00.19
190.85
190.85
0d:00:00:00.282
282.2
282.2
0d:00:00:00.021
21.3
21.3
0d:00:00:00.292
292.05
292.05
0d:00:00:00.177
177.35
177.35
0d:00:00:00.217
217.35
217.35
0d:00:00:00.351
351
351
0d:00:00:00.461
461.75
461.75
0d:00:00:00.468
468.9
468.9
0d:00:00:00.472
472.9
472.9
0d:00:00:00.485
485.8
485.8
0d:00:00:00.492
492.85
492.85
0d:00:00:00.437
437.75
437.75
0d:00:00:00.006
6.6
6.6
0d:00:00:00.011
11.85
11.85
0d:00:00:00.056
56.6
56.6
0d:00:00:00.073
73.85
73.85
0d:00:00:00.113
113.65
113.65

cluster trace pre_ post_ y0_mV
_id
_num ms ms
1
1
1
1
1
1
1
1
1
1
none
1
none
1
1
1
1
1
2
2
1

1
1
1
1
1
1
1
1
1
1
1
1
1
1
1
1
1
1
1
1
1

1
1
1
1
1
1
1
1
1
1
1
1
1
1
1
1
1
1
1
1
1

2.5
2.5
2.5
2.5
2.5
2.5
2.5
2.5
2.5
2.5
2.5
2.5
2.5
2.5
2.5
2.5
2.5
2.5
2.5
2.5
2.5

0.00913
0.006259
0.002066
0.003162
-0.00199
0.002024
-0.0154
0.005864
0.002684
0.00163
0.001753
0.004138
-0.00232
0.004636
-0.00255
0.003172
0.005892
-0.00646
0.003823
-0.00664
-0.00189

y1_mV
0.00948
0.005788
0.002188
0.003685
-0.00099
0.002668
-0.01643
0.006522
0.003227
0.002463
0.001386
0.005201
-0.00321
0.004055
-0.00276
0.001977
0.004139
-0.00638
0.00482
-0.00679
-0.00076

Figure 3-4.5. Time stamps and waveforms for clustered spikes saved as a “CSV” file displayed in Excel.
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3-4.2. Saving the spike frequency data
Check the “Enable” in the [Save Spike Freqs] and run the analysis workflow with the Green-Red button
to save the frequency data as a “CSV” formatted text file.

Figure 3-4.6. [Save Spike Freqs] module.
The Figure 3-4.7 is an example of the spike frequency data for clustered spikes saved (only for channel
5) as a “CSV” file displayed in Excel. The data include cluster ID (NC, C1, C2) since the
“Spike_sorting(_filter)” workflow template is used..

File Format 20071201
Session St 2003/12/15 18:13:29 +09
time_secs phase
1 Baseline
2
3
4
5
6
7
8
9
10
11

ch5
NC

ch5
C1
0
0
0
0
0
0
0
0
0
0
0

ch5
C2
6
13
1
17
2
9
4
11
3
9
7

ch5
C3
1
0
0
0
0
1
0
1
0
0
0

1
2
0
2
0
3
0
1
0
5
0

Figure 3-4.7.
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3-4.3. Saving the average chart
Check the “Enable” in the [Save Measure Averages] and run the analysis workflow with the Green-Red
button to save the averages and standard deviations as a “CSV” formatted text file. (Refer to
section 3-3.3. Compute averages of spike frequency by phases.)

File Format Version
Session Start Time

20080212
2008/10/01 16:16:43 +09

Channel Number 57
Measure
NC

Baseline
+/-sd
dose 1
+/-sd
dose 2
0.143
0.655
0.05
0.224
0.895

Channel Number 58
Measure
NC

Baseline
+/-sd
dose 1
+/-sd
dose 2
0.857
2.833
4.55
9.139
22.211

Channel Number 59
Measure

Baseline

+/-sd

dose 1

+/-sd

dose 2

Figure 3-4.8. Example of the average chart saved as a “CSV” file diplayed in Excel. (Only channel 57, 58, and 59 are
exported.)

3-4.4. Saving Centroids
The centroid waveforms (shown with solid lines at the [Display Extracted Spike (waveforms only)] are
saved as a “CSV” formatted text file by checking the storage/reload in the [Cluster Spikes] and running
the workflow with the Green-Red button.

CHANNEL
#Centroids

1
2

Centroid
1
sign
-1
ms
mV
0
0.0017
0.05
0.0051
0.1
0.0057
0.15
0.0064
0.2
0.0071
0.25
0.0077
0.3
0.0081
0.35
0.0083
0.4
0.0085
0.45
0.0087
0.5
0.0085
0 55
0 0075

Figure 3-4.9. Example of the centroids saved as a “CSV” file displayed in excel.
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4-1. Recording of spontaneous myocardial signals

Chapter 4

Mobius QT

This chapter describes how to record and analyze signals from cardiac myocyte cultures, acute heart
tissue, or stem cell derived cardiac myocytes using available workflow templates.

4-1. Recording of spontaneous myocardial signals
There are 3 workflow templates available for recording spontaneous myocardial signals.
1. Simple_recording:
For recording myocardial signals (long spikes) WITHOUT any analysis.
2. Beat_recording:
For recordings with extracting myocardial signals (long-spikes), and measuring their
frequencies and inter-spike intervals.
3. QT_recording:
For recordings with extracting myocardial signals (long-spikes), measuring their frequencies and
analyzing extracted waveforms. Use this workflow template for the Field Potential Duration (FPD)
analysis.
After reading this section you should be able to record spontaneous myocardial signals using any of the
above workflow templates.
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4-1.1. Overview of the acquisition workflow templates
“QT_recording” workflow template
The "QT_recoding" workflow template consists of following modules located in the “Main”, “Detect beating”, and “Measurement” tabs.

Tab

Modules

Main

Acquire MED64R2 Data / Dis play All Channels

Detect beating

Extract Long Spikes /Dis play Extracted Spikes / Com pute Inters pike Intervals / Dis play
Inters pike Intervals / Save Inters pike Intervals

Meas urem ent

Filter Spike Data (2) / Extract Spike Meas ures / Save Meas ures Data / Dis play Res ults
Table

“Main” Tab
“Detect beating” Tab
“Measurement” Tab

Figure 4-1.1. Module configuration for the “QT_recording” workflow template.
With this workflow template, spikes (myocardial signals) crossing pre-determined thresholds are
extracted. The extracted long spikes are filtered according to the selected drop down filter options in
the [Filter Spike Data] module, and then sent to the [Extract Spike Measures] module, where a variety
of waveform analyses can be performed and graphed (e.g., amplitude, slope, area, and peak to peak
time etc.). The inter-spike intervals for the extracted long spikes are also computed and graphed. Use
this workflow template if your interest is waveform analysis including field potential duration (FPD) for
studying QT prolongation.
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Acquire MED64R2 Data

Extracted Long Spikes

Compute Interspike Intervals

Save Interspike Intervals

Display All Channels
Display Extracted Spikes

Filter Spike Data

Display Interspike Intervals
Save Measures Data

Extract
Spike
Measures

Display Results Table

Figure 4-1.2. Control panels for the “QT_recording” workflow template. “Main” tab (top-left), “Detect beating” tab,
(top-right), and “Measurement” tab (bottom).
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“Beat_recording” workflow template
The “Beat_recording” workflow template consists of following modules located in the “Main” and
“Detect beating” tabs.

Tab
Main
Detect beating

Modules
Acquire MED64R2 Data / Display All Channels
Extract Long Spikes / Compute Beats per Minute / Save Beats pre Minute / Display Beats
per Minute / Compute Interspike Intervals / Save Interspike Intervals / Display Interspike
Intervals / Display Extracted Spikes

With this workflow template, long spikes (myocardial signals) crossing pre-determined thresholds are
extracted, and their beat frequencies (beats per minute) and interspike intervals are measured and
graphed. Use this template if your interest is beat frequency.

“Main” tab
“Detect beating” tab

Figure 4-1.3. Module configuration for the “Beat_recording” workflow template.

“Simple_recording” workflow template
Signals are acquired, and the acquired signals are displayed at all 64 channels.

Figure 4-1-4. Module configuration for the “Simple_recording” workflow template.
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Acquire MED64R2 Data

Extract Long Spikes

Display Beats per Minute
Display
Interspike
Invervals

Display All Channels
Compute Beats per Minute (top)
Save Beats per Minute (bottom)

Compute Interspike Intervals (top)
Save Interspike Intervals (bottom)
Display Extracted Spikes

Figure 4-1.5. Control panels for the “Beat_recording” workflow template. “Main” tab (left) and “Detect beating” tab
(right).

Opening the workflow template
1.

Click [Workflow] > [New] > [From Template]. (Figure 4-1.6)

2.

Select [64MD1_1280x1024] or [64MD_1920x1080] folder, depending on the size of your display
monitor.

3.

Select [QT] > [Spontaneous_recording] folder, and then any of the recording workflows.

NOTICE:
Connect your PC to the MED64 amplifiers and turn on both amplifiers to open the recording worfklows.

Figure 4-1.6. Opening workflow template.
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4-1.2. Setting the acquisition parameters
All the acquisition workflow templates include the [Acquire MED64R2 Data] module. Acquisition parameters are set in this module.
NOTICE:
Connect your PC to the MED64 amplifiers and turn on both amplifiers to open this module.

(5)

(1)
(6)
(2)
(8)
(3)

(7)
(9)

(4)
Figure 4-1.7. [Acquire MED64R2 Data] module.
(1) # Traces: Number of Traces (sweeps).
(2) Auto Pause:

Mobius will pause automatically when the current trace is finished if this box is checked. The trace
interval set below becomes invalid when this box is checked. Mobius re-starts by clicking either of
Green button or Green-Red button.
(3) Trace duration: Sampling (Recording) time for each trace.
(4) Trace interval:
Interval between traces. (from the beginning of the first trace to the beginning of the next trace.)
• Signals are recorded for 2 minutes every 3 minutes 5 times in the default setting as seen in
the following figure. Mobius will run for 15 minutes total.
2 min.

•

2 min.

Recording
3min.
The trace interval becomes invalid when Auto Pause is checked.

(5) Input Range (mV):
Maximum input signal level. This setting should be adjusted according to the signal amplitude to
achieve the maximal dynamic range. Select 2.3 mV, 2.9 mV, 5 mV, 12.5 mV, or 25 mV. Larger number
for the Input Range creates lower voltage resolution.
2.9 mV is set in the default. This is the Input Range recommended for the field potential duration
analysis combined with 1 kHz for the “High cut freq” (low-pass filter) to achieve the stability for the
repolarization (K+ efflux) peak time. Change it depending on the size of your signals, purpose of your
analysis, and/or the parameter selected for “High cut freq”. It is highly recommended that you
change it to 5.0 mV (or greater) when 10 kHz is selected for the “High cut freq”.
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(6) Low cut freq (Hz):
High pass filter for the amplifier. Select 0.1 Hz, 1.0 Hz, 10 Hz or 100 Hz. If 1.0 Hz is set, the signals
with frequencies lower than 1.0 Hz are filtered out. 1.0 Hz is typically recommended for the recording
of myocardial signals.
(7) Channels:
Select the channels for recording here. When the square box is clicked, the channel selector pops up.
The enabled recording channels are colored green.
(8) High cut freq (Hz):
Low pass filter for the amplifier. Select 1000 Hz, 2,000 Hz, 2500 Hz, 5000 Hz, 7500 Hz, or 10000 Hz.
If 5000 Hz is selected, signals with frequencies higher than 5000 Hz are filtered out.
1000 Hz is typically recommended for the field Potential duration analysis to achieve the stability for
the repolarization (K+ efflux) peak time. Change it depending on the analysis you would like to
perform.
(9) Save raw data:
When Mobius is started by clicking the Green-Red recording button while the [Enable storage] is
checked, the raw data is saved. The file name can be modified.

4-1.3. Execution button
Acquisition is initiated by running an acquisition workflow. Clicking the Green button runs the
acquisition workflow without saving data while clicking the Green-red button runs the acquisition
workflow while saving data to disc.

Stop

Run WITHOUT Run WITH
saving data
saving data

Pause

Figure 4-1.8. How the execution buttons work for acquisition.
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4-1.4. Before starting your experiment
When a recording workflow is run with Green or
Green-Red button for the first time after it is opened (or
made), Mobius needs several seconds for the calibration (as seen in the pop-up message). Acquisition starts
automatically after the calibration.
If you would like to start acquisition immediately after
clicking the Green-Red button, run the workflow with
the Green button for several seconds, and then stop it
before starting your experiment. When the workflow is
run for the next time, it will not require calibration and
acquisition will start immediately.

Figure 4-1.9. The pop-up message for the
calibration.

CAUTION:
•

Make sure that the hard disc drive has enough free space when you start long-term recording.
Recording with all 64 channels for 1 hour creates a 9.216GB file.
(9.216GB is 9,000,000KB, 8,739.06MB, or 8.58GB in Windows.

•

Avoid saving data to the drive where the OS is installed (usually C drive). Save it to a separate hard
drive, that is internal or eSATA-supported.

4-1.5. Recording spontaneous cardiomyocyte signals
Extraction of long spikes and online analysis require powerful computation and needs to be used carefully during acquisition. Thus, it is recommended to record signal WITHOUT analysis (by disabling the
spikes’ extractions) until you are familiar with your experiments. When acquisition with analysis is
made, please follow the cautions below:
CAUTION:
•

Minimize the channels for spikes’ extractions.

•

Avoid enabling any [Export] or [Save] modules when raw data is saved. Once raw data is saved,
you can export post-acquisition.

•

Set the trace duration (recording time) to less than 10 minutes and the trace interval to longer than
“the trace duration x 2” so that the analysis can catch up with the acquisition during the trace interval. Particularly, keep the trace duration short for long-term recording lasting days, weeks, or
months.

•

Set the thresholds as low as possible for negative signals (high for positive signals) so that other
components of the signals or noise are NOT extracted as spikes.

•

Make sure to pause Mobius with the yellow button when a drug is applied.
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1.

Modify the #Traces, Trace duration, and Trace interval in the [Acquire MED64R2 Data] module.
(Refer to page 98, section 4-1.2. Setting the acquisition parameters.)

2.

Start running the workflow with the Green button to have signals on the screen, and then stop.

3.

Select the channel for acquisition.
1) Click the box next to the “Channels” in the [Acquire MED64R2 Data] module to open the channel
selector. (Figure 4-1.11)
2) The recording channels are colored green and non-recording channels are colored red.

Figure 4-1.10. Selecting acquisition channels
4.

Open the “Detect beating” tab. Select a channel for spikes’ extractions. The default has all channels
with “checked”. Click the check box to diable them. The setting can be applied to all other channels
by right-clicking and selecting [Apply to All].
•

5.

It is recommended to select only one channel for spike extraction and analysis during acquisition although it is possible to select more than 1. Once data is saved, all analysis can be performed post-acquisition. Particularly, select only one channel when acquisition is made with
[Extract Spike Measures] analysis from non-synchronized signals. Otherwise, the waveform
cannot be captured on the [Extract Spike Measures].

Set the thresholds by typing the number in the chart of Extract Long Spikes (Refer to page 114).

Figure 4-1.11. Extract Long Spikes module. Channel 51 is selected for extraction. For the Ch 52, data is saved but
spikes are not extracted (analysis is not observed.)

6.

Set the analysis parameters for the analysis module (Refer to page 113-125).

7.

Open the “Main” tab. Make sure “Enable storage” is checked in the “Save raw data” on the [Acquire
MED64R2 Data] module.
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8.

Save it as your own acquisition workflow by clicking [Workflow] > [Save
as]. (Figure 4-1.12)

9.

Start Mobius with Green-Red button.
•

•

Mobius will require you to save the workflow as your own if you try
to start Mobius with the Green-Red button without having saved it
already.

The data file (.modat file) and the Analysis workflow (including all
analysis module selected for the Acquisition workflow and [Replay Raw Data File] module will
be saved in the same folder.

Figure 4-1.13. Recording cardiomyocyte signals with analysis .
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Figure 4-1.12.
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4-2. Drug testing
The [Compute Measure Averages] module calculates averages and standard deviations for the waveform analysis (Extract Spike Measures), beat frequencies, and interspike intervals for all the experiment's phases. This is a useful tool for making a dose-response curve or comparing phases before,
during and after drug application. This section will demonstrate how to add "phase bars" so as to make
a dose-response curve easily and quickly post-acquisition.
1.

Open the “QT_recording” or “Beat_recording” workflow template.

2.

Set the acquisition parameter and check the “Auto Pause” check box.
(Figure 4-2.1) Acquisition will be PAUSED automatically after each
trace recording is finished.

3.

Set the analysis parameters (refer to page 113-). Save it as your
own workflow. ([Workflow] > [Save as])

4.

Open the Measurement tab. Start recording in Mobius with clicking
Green-Red button. The first phase (baseline) will start from time 0.

5.

After the first phase is completed, Mobius will pause automatically
and the “ACQUISITION PAUSED” pops up.

Figure 4-2.1. Checking the
“Auto Pause”.

Apply the drug and type the name for the 2nd phase in the box. (e.g. 100 nM E4031) (Figure 4-2.2)
•

Do NOT stop Mobius with the Black button. If it is stopped, the experiment will end and new
phases will not be added.

When you are ready for the next phase, click the OK button to re-start Mobius. A yellow bar with
chosen name appears on the charts in the [Extract Spike Measures] and [Display beat freq]. (Figure
4-2.3)

Figure 4-2.2. (Left) Adding a new phase.
Figure 4-2.3. (Right) A new phase added on the [Extract Spikes Measures].
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If the Auto-pause is not checked, go forward to the next
phases with following procedure:

1) Pause Mobius with YELLOW button.
•

Do NOT stop Mobius with the Black button.

2) Click [Annotations] > [Add New phase]. Type the
name for the 2nd phase. (Figure 4-2.4)
Figure 4-2.4
3) When the OK button is clicked, a yellow bar with the
chosen name will appear. (Figure 4-2.3)
4) Click the Green-Red button to re-start Mobius.

6.

When the 2nd phase is finished, Mobius pauses automatically again and the pop-up menu comes
up.

7.

Apply drug, and then type the name for the third phase. (e.g. 1000 nM E4031)

8.

Click OK button to re-start Mobius. The Figure 4-2.5 shows the [Extract Spike Measures] module
with added phase bars.

9.

The analysis workflow including all analysis parameters and phase bars you set are automatically
made in the same directory as the acquisition workflow. Use this analysis workflow to make a
dose-response-curve later. (Refer to page 124-126 for detailed instructions on how to make a
dose-response-curve.)

Figure 4-2.5. The [Extract Spike Measures] module with phase bars.
•

The phase bars can be added and saved to the analysis workflow even without extracting long
spikes. (Signals and analysis are not seen during recording in this case.)
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4-3. Replay and analysis of acquired spontaneous data
Mobius data files (.modat) are opened and replayed with the [Replay Raw Data File] module, and analyzed using modules such as [Compute Beat Frequency], [Compute Interspike Intervals], and [Extract
Spike Measures]. You will design your analysis workflow by combining those modules for replay and
analysis of the acquired data. The quickest way to replay and analyze the data is using the analysis
workflow templates, which will be introduced in this chapter.
The following analysis workflow templates are available for analysis of spontaneous myocardial data:
1.

QT_analysis:
Workflow for waveform analysis including field potential duration analysis (measurement).

2.

Beat_frequency_analysis:
Workflow for signal frequency analysis.

3.

Export_for_propagation_analysis_spontaneous:
Workflow for making a propagation map.

The Analysis workflow with the [Replay Raw Data File] and the analysis modules you selected for your
acquisition will be automatically saved to the same directory when you record with the Green-Red button. These workflow templates can also be used for quickly performing analysis.

4-3.1. Opening and replaying acquired data
1.

Open the analysis workflow.
1) Click [Workflow] > [New] > [From Template].
2) Select [64MD1_1280x1024] or [64MD1_1920x1080], depending on the size of your display
monitor.
3) Select [QT] > [Spontaneous_analysis] folders, then select a workflow template.
•

In order to open your own analysis workflow, click [Workflow] > [Open]. Select the analysis
workflow file (.moflo file).

Figure 4-3.1. Opening analysis workflow template.
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2.

Click the box next to the “Filename” and select the .modat file. When the file name appears in the
box (as seen on the left figure of the Figure 4-3.2), the data is ready to be replayed by clicking the
Green or Green-Red button.
•

3.

It can take several minutes to open large data sets. (e.g. Opening 10GB data can take over 1
minute.)

When the Green button is clicked, the acquired data is just replayed. Clicking the Green-Red button
while checking the “Enable” check-box executes the Export or Saves.
2

Figure 4-3.2. Opening a Mobius data file (.modat file).

Figure 4-3.3. Replayed spontaneous myocardial data.
Input fields for the [Replay Raw Data File] module
1.
2.
3.
4.

Traces: Selects the trace(s) for processing.
Trace time: Selects the trace time for processing.
Channels: Selects the channels for processing. Click the box next to the “Channels” to open the
channel selector. Channels in green will be enabled.
Delay: Set this value to a value greater than zero to insert a delay between data “blocks” sent out
by this module. It is useful for slowing down data processing.

106

Mobius Tutorial (MED-A64MD1): Chapter 4 - Mobius QT

4-3. Replay and analysis of acquired spontaneous data

4-3.2. Overview of the analysis workflow template
This section provides an overview of the workflow templates available for analysis of spontaneous myocardial signals.

“QT_analysis” workflow template
Use this workflow template for waveform analysis of the extracted myocardial signals (long-spikes)
including field potential duration analysis. This workflow template consists of the following modules
located in the “Main”, “Detect beating”, “Measurement”, and “Averages” tabs. Please refer to section
4-3.2 on field potential duration analysis (page 113-121) for instructions on how to use this workflow
template.
Tab

Modules

Main

Replay Raw Data File / Dis play All Channels / Export Raw Data
Extract Long Spikes / Dis play Extracted Spikes / Com pute Inters pike Intervals / Save
Inters pike Intervals / Dis play Inters pike Intervals
Filter Spike Data (2) / Extract Spike Meas ures / Save Meas ures Data / Dis play Res ults
Table (for Eextract Spikes Meaus res )
Com pute Meas ure Averages (for Extract Spike Meas ures ) / Save Meas ure Averages (For
ESM)

Detect beating
Meas urem ent
Averages

The replayed raw data is sent to the [Extract Long Spikes] module where long spikes crossing
pre-defined thresholds are extracted. The extracted long spikes are filtered, and then sent to the
[Extract Spike Measures] module where their amplitude, slope, time, or area is measured and graphed.
The [Display Results Table] shows the values for the analyses performed with the [Extracted Spike
Measures].
The [Compute Measure Averages] module computes and graphs the averages of the waveform analysis. The extracted long spikes are sent to the [Compute Interspike Intervals] module for their interspike
intervals to be analyzed as well. Raw data can be exported as a binary or ASCII ("CSV" formatted text
file). The measurement chart and average chart can be saved as "CSV" formatted text file.
Replay Raw Data File
Display
All Channels

“Main” tab
Export
Raw Data

Extract Long Spikes

“Detect beating” tab
“Measurement” tab

Display
Extracted Spikes

Save ISI

Compute
Interspike Intervals

Filter Spike Data

Display ISI

Filter Spike Data

“Averages” tab

Extract Spike Measures

Save Measures Data

Display Results Table

Compute Measure
Averages
Save Measure
Averages

Figure 4-3.4. Module configuration for the “QT_analysis” workflow template.
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Compute Interspike Intervals

Save ISI

Extract Long spikes

Display Extracted
Spikes

Display Interspike
Intervals

Save Measures Data
Filter
Spike Data

Extract Spike
Measures

Display Results
Table

Save Measure Averages

Compute Measure
Averages
(for Extract Spike Measures)

Figure 4-3.5. Control panels for the “QT_analysis” workflow template. “Detect beating” tab (top), “Measurement” tab
(middle), and “Averages” tab (bottom).
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“Beat_frequency_analysis” workflow template
Use this workflow template if your interest is beat frequency analysis. The "Beat_frequency_analysis "
workflow template consists of following modules located in the “Main”, “Detect beating”, and “Averages” tabs. Please refer to section 4-3.3, Beat frequency analysis (page 122-123) for instructions on
how to use this workflow template.

Tab
Main

Modules
Replay Raw Data File / Display All Channels / Export Raw Data
Extract Long Spikes / Display Extracted Spikes / Compute Beats per Minute / Save Beats per
Detect beating Minute / Display Beats per Minute / Compute Interspike Intervals / Save Interspike intervals /
Display Interspike Intervals
Averages
Compute Measure Averages (for ISI) / Save Measures Averages (For ISI)
The replayed raw data is sent to the [Extract Long Spikes] module in which long spikes crossing
pre-defined thresholds are extracted. The extracted long spikes are sent to the [Compute Beats per
Minute] module for measuring their frequencies as well as [Compute Interspike Intervals] module for
measuring interspike intervals. The [Compute Measure Averages] module computes and graphs the
averages of the interspike intervals.
The raw data can be exported as Binary or ASCII ("CSV" formatted text file). The beat frequency chart,
inter-spike-interval chart, and averages chart can be saved as a "CSV" formatted text file.

“Main” tab
“Detect beating” tab
“Averages” tab

Figure 4-3.6. Module configurations for the “Beat_frequency_analysis” workflow template.
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Extract Long Spikes
Display Beats
per Minute
Display

Compute Beats
per Minute
Save Beats
per Minute
Compute
Interspike intervals
Save Interspike
intervals
Display Interspike
Intervals

Display Extracted
Spikes

Compute Measure
Averages (for ISI)

Save Measure
Averages
(for ISI)

Figure 4-3.7. Control panels for the “Beat_frequency_analysis” workflow template. “Detect beating” tab (top) and
“Averages” tab (bottom).
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“Export_for_propagation_ analysis_spontaneous” workflow template
This workflow template allows you to export the time stamps of the extracted long spikes with a “CSV”
file. This is useful for creating a propagation map. It consists of following modules located at 3 Tabs.
Please refer to section 4-3.6. Propagation analysis for spontaneous data (page 127-129) for instruction
on how to use it.
Tab

Modules

Main
Filter

Replay Raw Data File / Dis play All Channels
Filter Raw Data (2) / Dis play All Channels

Detect beating

Extract Long Spikes / Save Spikes / Extract Spike Meas ures

The replayed raw data are filtered, and then sent to the [Extract Long Spikes] module, in which long
spikes crossing pre-defined thresholds are extracted. The [Save Spikes] module allows you to save the
Time Stamps of the extracted long spikes as a “CSV” file.

Replay Raw Data File

Filter Raw Data

Display
All Channels

“Main” tab
“Filter” tab
“Detect beating” tab

Filter Raw Data

Extract Long Spikes

Save Spikes

Display
All Channels

Display
Extracted Spikes

Figure 4-3.8. Module configurations for “Export_for_propagation_analysis_spontaneous” workflow template.
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Filter
Raw Data

Display All
Channels
(for filtered
data)

Extract Long Spikes

Save Spikes

Display Extracted Spikes

Figure 4-3.9. Control panels for the “Export_for_propagation_analysis_spontaneous” workflow. “Filter” tab (left) and
“Detect beating” tab (right).
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4-3.3. Field potential duration analysis
-Analysis for extracted long spikes’ waveforms with the “QT_analysis” workflow template-

1.

Open the “QT_analysis” workflow template, and then the data file. (Refer to page 107)

2.

Replay the data by clicking the Green button, and then stop. Select a channel for analysis. Check
“On” box for the selected channel in the [Extract Long Spikes] module.
Or, channel(s) for analysis can be selected by the channel selector in the [Replay Raw Data]. (The
channel selector pops up when the box next to channels on the [Reply Raw Data File] module is
clicked.)

Figure 4-3.10. Selecting analysis channel with the “On” check box in the [Extract Long Spikes].

Notice:

3.

•

It is recommended to select only one channel to speed up your analysis although it is possible
to select more than 1 channel. (Extraction of long spikes and following analysis require powerful computation.)

•

Select one channel particularly when signals are NOT synchronized. Otherwise, the waveforms
cannot be captured in the [Extract Spike Measures].

Open the “Detect beating” tab, and and set thresholds.
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How to set thresholds
•

Check the [ON] check box to activate spikes’ extractions.
-Green shows data is acquired (or processed for replay) while Red does not.

•

The numbers for Thresholds and Pre/Post times can be changed by double-clicking
and typing numbers directly on the chart (Figure 4-3.11).

•

Pre/Post times must be identical for all 64 channels. Different numbers can be
selected for thresholds.

•

The number changed for threshold can be applied to all other channels by right-clicking the number and selecting Apply to All (Figure 4-3.12).

Figure 4-3.11. Setting the thresholds for channel 29 by typing the number in the chart.

Figure 4-3.12. Apply to ALL button.

Notice:
•

It is not recommended to set thresholds both for + and -. Select either one for detecting long
spikes.

•

Set the thresholds as low as possible for negative signals (high for positive signals) so that
other components of the signals are NOT extracted as spikes. (Figure 4-3.13)
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Figure 4-3.13. Bad example for spikes’ extrication.
4.

Replay data with Green button. The long spikes extracted are high-lighted in light green on the left
chart of [Display Extracted Spikes] and waveforms of extracted long spikes are displayed on the
right chart. (Figure 4-3.14)

Figure 4-3.14. Long spikes are extracted (high-lighted with light green color).

How to modify the charts in the [Display Extracted Spikes]
[Trace] chart (left):
•

The scale for amplitude (Y axis) can be changed by clicking and typing in the desired
minimum and/or maximum values (Figure 4-3.15).

•

The time duration (X axis) can be changed in the “Duration” drop down menu.
(Figure 4-3.16)

Figure 4-3.15. (Left) Changing the scale for amplifier.
Figure 4-3.16. (Right) Chancing the time duration.

[Extracted Spikes] chart (right):
•

The scale for amplitude and time can be changed by clicking and typing in the
desired minimum and/or maximum values. (Figure 4-3.15)

•

The scale can be adjusted automatically by clicking [Autoscale] button or double-clicking anywhere on the chart.
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5.

Open the “Measurement” tab by clicking the tab name. The extracted long
spikes are filtered before they are sent to the [Extract Spike Measures] module. In the default setting, the “Bessel low pass 9 pole with 1000 Hz” and
“None” are selected. Modify the filter type and cut-off frequencies depending
on your signals. (Figure 4-13.17)

Figure 4-3.17.

6.

Set the waveform analysis parameters in the [Extract Spike Measures] module.
The "Time of Amplitude Min To Max" is the default setting. This measures the “duration” from
the time point for signal’s minimum amplitude between the 2 cursors on the left to the time point
for signal’s maximum amplitude between 2 cursors on the right (Figure 4-3.18). Set the cursors by
left-clicking and dragging them. Or, change the analysis menu. Similar analysis includes: “Time of
Amplitude Max to Max, Max to Min, Min to Mim”.

Figure 4-3.18. Definition of the “Time of Amplitude Min to Max” (left) and how to select the measurement type (right).
7.

In order to change the measurement type, click [Edit Measures] button, and then select different
analysis (measurement) with the drop-down menu for the “Measure Type”. (Figure 4-3.18)
•

8.

Please refer to page 119-121 for detail about the [Extract Spike Measure] module.

Replay data with the Green button. When you are satisfied with your
analysis parameters, save this as your analysis workflow. (Figure
4-3.19) The measurement chart can be saved as a “CSV” text file when
the workflow is run with Green-Red button while checking the “Enable”
check box for [Save Measure Data] module is checked. (Refer to section
4-7. Data output on pages 151-154 for details.
Figure 4-3.19.

•
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The “QT_analysis” workflow template includes the modules for inter spike intervals. Please
refer to section 4-3.4. Beat frequency analysis on pages 122-123 for details.
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Figure 4-3.20. Field potential duration analysis. The time between peaks are measured with the “Time of Amplitude
Max to Max” protocol and graphed (middle-right). The numbers are shown on the [Display Results Table] module (bottom).
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Other available analysis (Measures) for analyzing field potential duration
Time of Crossing Horizontal Cursor
•

Computes the “time” from the left-most vertical cursor (“Cursor 1”) to the first intersection of the
extracted spikes with the horizontal cursor AFTER the right-most vertical cursor (“Cursor 2”). (Figure 4-3.21)

Time of Crossing
Horizontal Cursor

Cursor 1

Cursor 2

Figure 4-3.21.

Time of Slope Crossing Horizontal Cursor
•

This measure uses four cursors as shown in Figure 4-3.22 - three vertical and one horizontal. It
computes the “time” from the left-most vertical cursor (“Cursor 1”) to the intersection of the linear
fit slope line computed on the data between the second and the third vertical cursor (“Cursor 2” and
“Cursor 3”) with the horizontal cursor. (Figure 4-3.22)
Time of Slope Crossing
Horizontal Cursor

Liner line

Cursor 2
Cursor 1

Cursor 3

Figure 4-3.22.
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[Extract Spike Measures] module
This module allows you to perform waveform analysis for extracted long spikes. Time, amplitude, slope,
and area can be measured and graphed.

Raw data chart

1

2

Measurement chart

3

4

5

6

7

8

9

10

Input fields

Figure 4-3-23. [Extract Spike Measures] module.

Raw data chart
The raw data chart on the left shows the extracted long spikes’ waveforms. The cursors for the measurements are shifted by left-clicking and dragging.
You can zoom in on the Raw data chart by:
•

Left-clicking and dragging while pressing the shift button.

•

Changing the maximum (and/or minimum) numbers for both X (time)
and Y (amplitude) axis. Click, and then, type in the new value(s) for the
maximum and/or minimum. (Figure 4-3.24)
•

Figure 4-3.24.

The scale can be adjusted automatically by double clicking anywhere on this chart.

The cursor locations can be copied to all or specific channels by
right-clicking and selecting the [Apply Cursors to All Channels] or [Copy
Cursors]. Select [Apply Cursors to All Measures] to copy the cursor
locations to all measures. (Figure 4-3.25)
Selecting [Copy Data] allows you to copy the waveform data for the
selected channel and paste to an excel worksheet. (Figure 4-3.25)
Figure 4-3.25.
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Measurement chart
The time course for the selected measurements is graphed here. Zoom in or out by changing the maximum (and/or minimum) values for the X and/or Y axis. Click and type in the new values directly.
Right-clicking anywhere in the chart and selecting [Copy Data] allows you to copy the measurement
data for selected channel(s) and paste to an excel worksheet (Figure 4-3.27). Selecting [Capture
Image] allows to copy the chart image.
TimeOfAmplitudeMinToMax(ms)
148.05
161.65
156.1
162.9
156.75

Figure 4-3.26. Copy data.

Input fields for the [Extract Spike Measures] module
1.

Channel No: Selects the channel for display.

2.

“Average” check box + “Traces” dropdown:
Check this box to average extracted spike waveforms. Set the number of traces to determine how
many traces will be averaged (e.g. If 3 is input and the box is checked, every three traces (-1st,
2nd, and 3rd / 2nd, 3rd, and 4th / 3rd, 4th, and 5th) are averaged and plotted.

3.

“Capture” button:
Click the Capture button on three different waveforms
to capture each of them on the screen. (Figure 4-3.27)
Additional clicking will drop and replace the oldest capture with a new one. Right-click on the [Capture] button to expose a menu of options for clearing captured
waveforms. Useful for comparing the waveforms in different phases.

4.

“X-labels” checkbox:
Check this box to display the X-axis positions of the
cursors in the left Raw data chart.

5.

“Reset Cursors” button:
If zooming operations have caused the cursors in the left Raw data chart to move out-of-sight, click
this button to bring them back into view.

6.

“Probe” dropdown:
This input field will be fully enabled in future upgrade.

7.

“Sync Thresh % dropdown” + “Windows ms” dropdown:
This feature is helpful only when more than one channel is analyzed at once. (Selecting more than
1 channel is NOT recommended in current version of Mobius.) You can detect long spikes and filter
out unexpected noise by requiring that a certain percentage of active channels (“Sync Thres”) produce long spikes within a certain window of time (“Window”). It is useful to view the output of this
panel in [Display Results Table] when adjusting these settings, because you can quickly see which
channels are not producing synchronized responses, and deactivate them.
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Figure 4-3.27
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8.

“Hide Phases” check box:
The phase bars (yellow bars with characters on the measurement chart) are hidden when this button is clicked.

9.

“Autoscale Measures” check box:
When this box is checked, the scale for the measurement chart is automatically adjusted. You can
zoom in and out in the measurement chart by typing values in the X and Y axes' limits when the
Autoscale button is NOT checked.

10. Edit Measures: Click this button to select or change the analysis (measurement) menu.
1) Select the analysis (measurements) you desire from the [Measure Type] box to change the default
measures. (Figure 4-3.28)
2) You can name the selected measures by double-clicking and typing the desired name directly into
the [Custom name] box.
3) To perform more than one analysis (Measure), click [Add Measures] button so another row on
the table and new measurement chart appears. (It is NOT recommended to select more than 1
measure during acquisition because it can slow down analysis significantly.)
4) You can delete unnecessary measurements by right-clicking the [Custom Name], and selecting
[Delete].
•

Click [Measures Help] button for detailed information on measurements.

5) The table shows the cursor values. Cursors can also be adjusted by changing numbers in this
table.
6) Click the [Hide] button to close the editor.

3)

4)

Figure 4-3.28. Edit Measures.
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4-3.4. Beat frequency analysis
The [Compute Beats per Minute] and [Compute Interspike intervals] modules in the
"Beat_frequency_analysis" workflow template are used.

1.

Open the analysis workflow template and data file. (Refer to page 105)

2.

Replay the data by clicking the Green button, and then stop.

3.

Open the “Detect beating” tab. Select channels for analysis. Check “On” box for the selected channel in the [Extract Long Spikes] module.
Or, channel(s) for analysis can be selected by the channel selector in the [Replay Raw Data]. (The
channel selector pops up when the box next to channels on the [Reply Raw Data File] module is
clicked.)
Set the thresholds in the [Extract Long Spikes] module by following instructions described at How
to set thresholds at page 114.

Figure 4-3.29. Selecting analysis channel with the “On” checkbox in the Extract Long Spikes.
4.

The [Compute Beats per Minute] module builds a cumulative record of beat frequency changes. The
computations are made independently on all channels and displayed on the [Display Beats per Minute] control panel.
The default setting has 10 seconds selected for the Binning window size. Extracted long spikes are
counted every 10 seconds. Selecting "Trace" instead of "Arbitrary (s)" means that spikes are
counted for the whole trace (Figure 4-3.30).

5.

The [Compute Interspike intervals] measures the time between each successive spike and creates
a cumulative record of the changes. The computations are made independently on all channels and
displayed on the [Display Interspike Intervals] module.
The "Average Channel ISI" function in the [Compute Interspike Intervals] module measures the
average time between the two most recent spikes across all active channels (Figure 4-3.31).

Figure 4-3.30. (Left) Compute Beats pre Minute module.
Figure 4-3.31. (Right) Compute Interspike Intervals.
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•

The chart for the [Display Interspike Intervals] and [Display beats per minute] can be zoomed
in or out by changing the maximum (and/or minimum) values for the X and/or Y axis. Click
and type in the new values directly. (Figure 4-3.32)

Figure 4-3.32.
6.

Replay data with Green button. When you are satisfied with your analysis parameters, save this as your analysis workflow. (by clicking [Workflow] > [Save As]) (Figure 4-3.33)

7.

In order to save these charts as "CSV" text files, check the “Enable” box
on the [Save Beats per Minute] (and/or [Save Interspike Intervals]),
then replay data with GREEN-RED button. (Refer to section 4-7. "Data
output on pages 151-154).

Figure 4-3.33.

Figure 4-3.34. Analysis performed with the “Beat_frequency_analysis” workflow template. Beats (long spikes) are
counted by every 10 seconds and displayed on the [Display Beats per MInute] module. (top-graph) Interspike intervals
are measured and graphed in the [Display Interspike Intervals] module (center graph). The bottom graphs show long
spikes that are extracted over time (high-lighted with light-green) (left) and each extracted long spike (right).
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4-3.5. Making a dose-response-curve
This section will walk you through making a dose-response curve with the field potential duration from
the acquired data. The Mobius' [Compute Measure Averages] module computes averages and standard
deviations of:
1) waveform analysis selected at the [Extract Spike Measures].
2) beat frequencies.
3) interspike intervals.

How to add [Compute Measure Averages] module to your analysis workflow
1.

Open the analysis workflow which was automatically made when you acquired the data.
(Go to [Workflow] > [Open].)

2.

Add the [Compute Measure Averages] module to this analysis
workflow.
1) Create a new tab by clicking [Layout] > [Add Tab] and typing
the name for this tab. (Refer to Figure 4-3.35)
2) Open the new tab, and then open the “Mobius Editor” by clicking
[Workflow] > [Edit]. (Figure 4-3.36, left figure)
3) Click the [Extract Spike Measures] on the left “Workflow” box,
and then double-click the [Compute Measure Averages] on the
Figure 4-3.35. Adding a new tab.
right “Available task panels” box. Now you will see that
[Compute Measure Averages] module shift to the left “Workflow” box and the control panel for this
modules appears on the new tab. (Figure 4-3.36).
4) Click the [Compute Measure Averages] on the left "Workflow” box, and then double-click the [Save
Measure Averages] on the right "Available task panels" box. The control panel for the [Save
Measures Averages] module will be displayed on your screen.

Figure 4-3.36. Mobius Editor was opened in a new tab and the [Extract Spike Measures] is clicked (left). The [Compute Measures Averages] was double-clicked and shifted to the left “Workflow” box. The control panel for this module
now appears (right).
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3.

Set the analysis parameters according to the instructions in 4-3.2. Field potential duration analysis
(pages 113-121).

4.

Run Mobius with Green button to replay the data to the end. You will see the phase bars you set
during your acquisition in the [Extract Spike Measures] module, and averages and standard deviations in the [Compute Measures Average] control panel. (Refer to Figure 4-3.37)

5.

The phase bars are shifted by clicking and dragging. The averages and standard deviations are
recalculated once Mobius is run with Green or Green-Red button after changing the locations of
phase bars.

•

If you are working with analysis workflow template or did not add phase bars during recording, add
phase bars according to the instructions on the next section, “How to add phase bars”.

Figure 4-3.37. The results of “Time of Amplitude Max to Max” with phase bars in the [Extract Spike Measure] (top) and
the averages and standard deviations for each phase displayed in the [Compute Measure Averages] control panel.

6.

In order to save the average chart, save it as your own analysis workflow first. ([Workflow] > [Save
as]) Check the “Enable” check-box on the [Save Measure Averages] module, then run Mobius with
the Green-Red button. (Refer to section 4-7. Data output on pages 151-154 for details.)
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How to add phase bars
Even if phase bars are not added during recording, they can be added later off-line using the following
procedure.
1.

Open the “QT_analysis” workflow template (or your own analysis workflow), and then open the
data file. (Page 105-106)

2.

Set the analysis parameters according to the instructions in the 4-3.2. Field potential duration analysis (page 113-122).

3.

Open the “Measurement” tab, and then replay the data with the Green button. You will see the first
phase, Baseline (yellow bar) is already at time 0.

4.

When the first phase is finished, pause Mobius with YELLOW button, and make a new phase.
•
•

Select [Annotators] > [Add New phase], then, type the name for the new phase. (Figure
4-3.38) Now you will see the new bar at the right chart of the [Extracted Spike Measures].
(Figure 4-3.39).
Do NOT stop Mobius with Black button. You will not be able to add more phases.

Figure 4-3.38. (Left) Adding a new phase bar.
Figure 4-3.39. (Right) A phase bar added on the [Extract Spike Measures].
5.

When the second phase finished, pause Mobius again and make a new phase.
*The location of the phase annotator (yellow bar) can be shifted later.

6.

Replay the data to the end. Averages and standard deviations are computed and graphed for each
phase (dose) in the Average tab. (Refer to Figure 4-3.37)

7.

In order to save the average chart, save it as your own analysis workflow first. Check the “Enable”
check-box on the [Save Measure Average] module, and run Mobius with Green-Red button. (Refer
to section 4-7. Data output on pages 151-154 for detail.)

Input fields for [Compute Measure Averages] module
1.

Channel:
The channel to be displayed is selected here. Channels can NOT be changed while running an
experiment.

2.

Use last:
If this box is checked, the selected (or typed) number of data points are used for computation. For
example, if 10 is selected, average and standard deviation are measured for the last 10 data points
in each phase.
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4-3.6. Propagation analysis for spontaneous data
This section describes how to generate a propagation map (distribution of the peak times) using the
“Export_ for_propagation_analysis_spontaneous” workflow template and excel. You will save the “time
for the amplitude peak” as a “CSV” file using this workflow template, and then generate a propagation
map using an excel file. The excel file (“Propagation_analysis_spontaneous”) is available from the Support page on the MED64 website. www. med64.com/Support.
CAUTION:
•

All 64 channels must have signals for the excel file to work.

1.

Open the “Export_ for_propagation_ analysis_spontaneous” workflow template (Refer to page
111).

2.

Open the data file, and replay the data by clicking the Green button.
(Refer to section 4-3.1. Opening and replaying acquired data on page 105)

3.

When the peak points in the original raw data are not clear enough, modify the filter menu so that
peak points are seen clearly.

4.

Set the thresholds for the all channels. (Refer to page 114)

5.

Replay data again to make sure you are satisfied with the new thresholds.

6.

Make sure that “Enable storage” is checked and
“Time stamps only” is selected in the [Save
Spikes] module (Figure 4-3.40).

7.

Save it as your own analysis workflow by clicking [Workflow] > [Save as].

8.

Click the Green-Red button so that the time
stamps for the peaks are saved as a “CSV” file.

9.

Open the “CSV” file with excel. (Figure 4-3.41 shows an example of the CSV file.)

Figure. 4-3.40. [Save Spikes] module.

10. Open the excel file, "Propagation_analysis_spontaneous". This file consists of 4 sheets of [data],
[analysis], [map_data], and [map]. You will copy some data to the [data] sheet. Propagation map
will be displayed in the [map] sheet.
11. Copy the data in the “within_trace_time_ms” for channel 1-64 (marked with red in the Figure
4-3.41) on your “CSV” file, and paste them in the second row on the [data] sheet in the
“Propagation_analysis_spontaneous” excel file.
Transpose Raw and Line.
12. A propagation map is generated in the “map” sheet of the “Propagation_analysis_spontaneous”
excel file (Figure 4-3.42).
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Figure 4-3.41. Top shows an example of data for saved time stamps displayed in excel. The data in the
“Within_trace_time_ms” (marked with red) is copied and pasted to the second row in the [data] sheet of
“Propatation_analysis_spontaneous” excel file
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Figure 4-3.42. A propagation map generated in the [map] sheet of the “Propagation_analysis spontaneous file.
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4-4. Recording of myocardial signals with pacing
The "Pacing_recording" workflow template is available for recording of myocardial signals with electrical
stimulation (pacing).

4-4.1. Overview of the “Pacing_recording” workflow template
The “Pacing_recording” workflow template consists of following modules located in the “Main” and “Pacing measures” tabs.
Tab

Modules

Main

Acquire MED64R2 Data w/Stim / Display All Channels / Export Raw Data
Extract Long Spikes, Filter Spike Data (2), Extract Spike Measures, Save Measures
Data, Display Extracted Spikes

Pacing measures

Acquisition and stimulation parameters are set in the [Acquire MED64R2 Data w/Stim] module. Signals
are extracted with the [Extract Long Spikes] module. The extracted signals are sent to the [Extract
Spike Measures] module, where extracted signals’ waveform analysis are performed (amplitude, slope,
time, and area). The raw data can be exported either as binary or ASCII data while the measurement
chart is saved as a "CSV" formatted text file.

“Main” tab
“Pacing measures” tab

Figure 4-4.1. Module configuration for “Pacing_analysis” workflow template.
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Acquire MED64R2
Data w/Stim.
Export Raw Data

Display All Channels

Extract Long Spikes
Display Extracted Spikes

Filter Spike Data
Save Measures Data
Extract Spike Measures
Figure 4-4.2. Control panels for “Pacing_recording” workflow template. ”Main” and “Pacing measures” tab.

Opening the workflow template
1.

Click [Workflow] > [New] > [From Template].

2.

Select [64MD1_1280x1024] or [64MD1_1920x1080] folder, depending of the size of your display
monitor. Select [QT] > [Pacing_recording] folder, and then the “Pacing_recording” workflow template.

NOTICE:
Connect your PC to the MED64 amplifiers and turn on both amplifiers to open the recording workflow.

Figure 4-4.3. Opening workflow template.
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4-4.2. Setting the acquisition and stimulation parameters
Acquisition and stimulation parameters are set in the [Acquire MED64R2 Data w/Stim] module. The
default setting will allow you to stimulate with intervals of 1 second for one minute using the function
“Repeat pattern to trace end”. Change the parameters depending on your experimental plan.
NOTICE:
Connect your PC to the MED64 amplifiers and turn on both amplifiers to open this module.

(11)

(9)
(10)
(1)

(4)

(5)

(6)

(2)

(7)

(8)

(3)

(13)

(15)

(16)

(17)

(18)

(14) (12)

Figure 4-4.4. [Acquire MED64R2 Data w/Stim] module.

Acquisition
1.

# Traces: Number of Traces (Sweeps).

2.

Trace duration: Sampling (Recording) time for each trace.

3.

Trace interval:
Interval between traces. (From the beginning of the first trace to the beginning of the next trace)
In the default setting, the Trace interval is invalid because the #Trace is set for 1. Select any number greater than 1 for # Trace to activate it.

4.

Input Range (mV):
Maximum input signals level. This setting should be adjusted according to the signal amplitude to
achieve the maximal dynamic range. Select 2.3 mV, 2.9 mV, 5.0 mV, 12.5 mV, or 25 mV. Larger
number for the Input Range creates lower voltage resolution.
2.9 mV is set in the default. This is the Input Range recommended for the Field Potential Duration
analysis combined with 1 kHz for the “High cut freq” (Low-pass filter) to achieve the stability for the
Repolarization (K+ efflux) peak time. Change it depending on the size of your signals and setting
for the parameter selected for “High cut freq”. Particularly change it to 5.0 mV (or greater) when 10
kHz is selected for the “High cut freq”.

5.

Low cut freq (Hz):
High pass filter. Select from 0.1, 1.0, 10 and 100 Hz. If 1 is set, signals with frequencies lower than
1 Hz are filtered out. The recommended filter setting for recording myocardial signals is 1.0 Hz.
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6.

Channels:
Select the channels for recording here. When the square box is clicked, the channel selector pops
up. Green shows enabled channels.

7.

High cut freq (Hz):
Low pass filter. Select 1000 Hz, 2,000 Hz, 2500 Hz, 5000 Hz, 7500 Hz, or 10000 Hz. If 5000 Hz is
selected, signals with frequencies higher than 5000 Hz are filtered out. Typically, 1000 Hz is recommended for the Field Potential Duration analysis to achieve the stability for the repolarization peak
time. Change it depending on the analysis you would like to perform.

8.

Save raw data:
When Mobius is started with Green-Red button while the [Enable storage] is checked, the raw data
is saved. Enter a descriptive file name of your choice.

Stimulation
Each Step is independent and can be programmed with different type of stimulation protocols. Enabled
steps will be applied in the order (1 to 8) at the intervals set in the Trace interval.
9.

Enable step:
When the box to the left of [Enable Step] is checked, the Step becomes valid. The default settings
have Step1 enabled and Steps 2-8 disabled (shown with # next to each Step).
•

For example, if both Step 1 and Step 2 are enabled, the Step 1 and Step 2 are applied alternatively at the interval set with the Trace interval.

10. Stimulator selector and check box:
Select the MED64 amplifier’s built-in stimulator (F1 or F2) here. Checking the box on the right of
“Stim” activates the selected stimulator. The default settings have F1 enabled for Step 1.
•

In order to stimulate through both stimulators simultaneously, enable both F1 and F2 stimulator in Step 1.

11. Stimulus channel selector:
Select stimulus channel here. The stimulus channel can be changed either by the drop-down or the
pop-up which appears by clicking the square box. The green shows the stimulus channel.
Mobius needs to be stopped (with Black button) or paused (with Yellow button) for the stimulus
channel to be changed.
12. Stimulus waveform editor:
Make your stimulus protocol here by selecting either [Const] or [Pulse] and typing in the desired
[Length] and [Amplitude]. Refer to Figure 4-4.5 for a schematic representation of a stimulus protocol example.
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pre stimulation time: 5 msec
post stimulation time: 994.40 msec
0.6 ms
Figure 4-4.5. Example of stimulus protocol and its schematic diagram.

•

Make sure that the STIMULUS CURRENT selection on the MED64 Head Amplifier
(MED-A64HE1S) is set to [NORMAL] to deliver the stimulus current amplitude set in Mobius.
Selecting [x2] doubles the output stimulus current amplitude set in Mobius.
(e.g. When 10 A is selected by Mobius with [x2] selected, the output stimulus current is 20
A. When -10 A is set in the Mobius with NORMAL selected, the output stimulus current
amplitude is 10 A)

•

The maximum stimulus amplitude set by Mobius is 100A. Set the STIMULUS CURRENT selector for x2 when stimulus amplitude with greater than 100 A is applied.

•

The maximum number of stimulus pulses to be programmed here at a Step is 21.

•

Do NOT select [Ramp] for the stimulation with the MED64. Only bi-phasic stimulation is recommended.

13. Repeat pattern to trace end check box:
When this box is checked, the stimulus protocol programed with the Stimulus waveform editor will
be repeated to the end of the trace.
In the default setting where the box is checked, stimulus pulses are delivered with interval of 1000
ms for 1 minute.

1000 ms 1000 ms

1 .0 min

Recording
Stimulus pulse

14. Add rev pol pulse check button:
When this box is checked, the other stimulator is automatically activated and creates the stimulus
waveform which has identical amplitude (uA) and length (ms) with REVERSED polarity to the given
stimulator.
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For example, if the box is checked at the default setting, F2 (that is not activated as default) is activated and has stimulus waveform with 50 uA and same duration to the F1
15. Reps selector:
The stimulus protocol set at the “Stimulus waveform editor” (11) is repeated the number of times
set here. Useful for multiple pulse stimulation.
In the default setting, this selector is invalid because the “Repeat pattern to trace end” is checked.
Uncheck the ”Repeat pattern to trace end” to activate this selector.
16. Stimulus current amplitude increment button:
When the + button is clicked, the absolute value of the stimulus current amplitude for the [Pulse] is
increment ed by the value set in the left box. (15*) For example, if 2 is set in the box (15) and the
+ button is clicked once, the stimulus amplitude will change to -12.00 A from -10.00 A. This is
useful for changing the stimulus amplitude for multiple pulse stimulations with just one click. The
absolute value of the stimulus amplitude can be decreased sequentially using the same procedure
when - button is clicked.
•

The stimulus current amplitude can be changed even during recording by using this button.
However, the changes are activated on the 2nd trace after the change since Mobius uses the
next trace to reset itself.

•

In the default setting, this button is invalid because the “Repeat pattern to trace end” is
checked. Uncheck the ”Repeat pattern to trace end” to activate this selector.

17. See #15.
18. Auto Inc check box:
When this box is checked, the stimulus current amplitude will automatically increase adding the
value (in A) set in the left box (15) to each preceding stimulation pulse. This is useful for making
I/O curves.
•

In the default setting, this check box is invalid because the “Repeat pattern to trace end” is
checked. Uncheck the ”Repeat pattern to trace end” to activate this selector.

4-4.3. Execution button
Acquisition is initiated by running an acquisition workflow. Clicking the Green button runs the
acquisition workflow without saving data while clicking the Green-red button runs the acquisition
workflow while saving data to disc.

Stop

Run WITHOUT Run WITH
saving data
saving data

Pause

Figure 4-4.6. Execution buttons
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4-4.4. Before starting your experiment
When a recording workflow is run with Green or Green-Red button for the first time after it is opened
(or made), Mobius needs several seconds for its calibration (as seen in the pop-up message). Acquisition starts automatically after the calibration.
If you would like to start acquisition immediately after clicking the Green-Red button, run the workflow
with the green button for a few traces with both stimulators un-enabled, and then stop before starting
your experiment. When the workflow is run the next time, Mobius does not require calibration but
acquisition will start immediately.

Figure 4-4.7. The left shows pop-up mesage for the calibration. Acquisition always starts after this message
dissaears. In order to start recording immediately after clicking the Green-Red button, run Mobius with the
Green button for a few traces with stimulator unenabled (right Figure) BEFORE starting your experiment.

4-4.5. Recording of cardiomyocyte signals with pacing
CAUTION:
•

Make sure that the hard disc drive has enough free space when you start long-term recording.
Recording with all 64 channels for 1 hour creates a 9.216GB file.
(9.216GB is 9,000,000KB, 8,739.06MB, or 8.58GB in Windows.)

•

Avoid saving data to the drive where the OS is installed (usually C drive). Save it to a separate hard
drive, that is internal or eSATA-supported.

•

Extraction of long spikes and following analysis require powerful computation and need to be used
carefully during acquisition. Mobius can appear to crash when it extracts more spikes than it can
analyze/display. This most often happens when there is noise or baseline fluctuation that crosses
the spike extraction thresholds on all channels at once. (e.g. unexpected noises cross the thresholds the baseline fluctuates due to vibration.)

•

It is strongly recommended you start your new experiments WITHOUT on-line (real- time) analysis (by disabling the spike detection).
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For pacing to cardiomyocyte, stimulating 2 adjacent electrodes simultaneously is recommended
to induce pacing activity more effectively. Make sure that the stimulus waveforms have identical
stimulus current amplitude and length but reversed polarities.
1.

Set the stimulus waveform for the F1 stimulator, and then click the [Add rev pol pulse] button. F2
stimulator will have an identical stimulus waveform with reversed polarity to the F1 stimulator.

Figure 4-4.8. Examples of the parameter for bipolar stimulation to adjacent electrodes. Both F1 and F2 are activated and their waveforms are identical except their polarities are reversed. Adjacent channels (ch 10 for F1 and
ch 18 for F2) are selected for stimulus channels.

2.

Change other parameters on the Acquire MED64R2 Data w/Stim module.
(Refer to section 4-4.2. Setting the acquisition and stimulation parameters on pages 133-136)
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How to change the stimulus pulse intervals
The default parameters will allow you to stimulate with the interval of 1000 msec for one
minute. In order to change the pulse intervals, change the post-stimulation time (994.80 ms
for default) .

1000 ms

700 ms

1000 ms

700 ms

700 ms

Figure 4-4.9. Changing the stimulus pulse intervals. Change the number for post-stimulus time.
The pulse intervals are shown as the “Single rep”.

3.

Run Mobius with the Green button.

4.

Select the channels for recording.
1) Click the box next to the “Channels” in the [Acquire MED64R2 Data] module to open the channel
selector. (Figure 4-4.10)
2) The recording channels are colored green and non-recording channels are colored red.

Figure. 4-4.10.
5.

Open the “Pacing measures” tab. Select a channel for spikes’ extractions. The default has all channels with “checked”. Click the check box to disable them. The setting can be applied to all other
channels by right-clicking and selecting [Apply to All].
•

It is recommended to select only one channel for spike extraction and analysis during acquisition although it is possible to select more than 1. Once data is saved, all analysis can be performed post-acquisition. Set the thresholds by typing the number in the chart of Extract Long
Spikes.
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Figure 4-1.11. Extract Long Spikes module. Channel 17 is selected for extraction. For the Ch 16,18-20, data is saved
while spikes are not extracted (analysis is not observed.)
6.

Set the analysis parameters and cursors.
(Refer to section 4-6.2. Analysis of the evoked potential data on pages 143-147)

7.

Save it as your acquisition workflow by clicking [Workflow] >[Save as].
(Figure 4-4.12)

8.

Make sure the “Save raw data” in the [Acquire MED64R2 Data w/Stim]
module is checked.

9.

Run Mobius with the Green-Red button.
Figure 4-4.12.
•

It is recommended without online analysis (by checking the Disable
button) unless you are familiar with your experiment and cells. (When the Disable button is
checked, no long spikes’ extractions or analysis can be displayed during recording.)

•

Mobius will require you to save the workflow as your own if you try to start Mobius with the
Green-Red button without having saved it already.

•

The data file (.modat file) and the Analysis workflow (including all analysis module selected for
the Recording workflow and [Replay Raw Data File] module) will be saved in the same folder.
(Refer to pages 17-18)

Figure 4-4.13. Recording of cardiomyocyte signals with pacing. The FPD analysis is performed using the
[Extract Spike Measures] module (right).
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4-5. Drug testing
The [Compute Measure Averages] module calculates averages and standard deviations for the waveform analysis (Extract Spike Measures). This is a useful tool for analyzing prolongation for the Field
Potential Duration with multiple doses. This section will demonstrate how to add “phase bars” so as to
make a dose-response curve easily and quickly later off-line.
1.

Open the “Pacing_recording” workflow template.

2.

Change the #Traces to the number for doses (or
more).

3.

Set a large number (e.g. 20 min) for the Trace
intervals which allows enough time to apply durg.

4.

Modify other acquisition and stimulation parameters
as you like.

5.

Set the analysis parameters in the Pacing measures
tab. (refer to page 143-147). save it as your own
workflow. ([Workflow] > [Save as]).

Figure 4-5.1. Example of parameters for drug
testing.

6.

Start recording in Mobius with clicking the GREEN-RED button. The first phase is started as “baseline” from time of 0.

7.

When the first trace is finished, Mobius will pause automatically. Once it is paused, click YELLOW
button so that the next trace will NOT start without clicking the Green-Red button.
•

8.

Do NOT stop with Black button. If it is stopped, the experiment will end and new phases will
not be added.

Apply the drug and add the 2nd phase.
Click [Annotations] > [Add New phase]. Type the name for the 2nd phase. (e.g. 100 nM E4031)
(Figure 4-5.2) When the OK button is clicked, a yellow bar with the chosen name appears in the
[Extract Spike Measures] (Figure 4-5.3)

Figure 4-5.2. (left) Adding the 2nd phase.
Figure 4-5.3. (right) Phase bar on the [Extract Spike Measures].
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9.

When you are ready for the second trace (phase), click GREEN-RED button to re-start Mobius.
Using this technique, you can start next phases without waiting for the end of trace interval.

10. When the 2nd trace phase is finished and Mobius pauses automatically, click YELLOW button again
not to re-start Mobius automatically.
11. Click [Annotations] > [Add New Phase], then type the name for the third phase. (e.g. 1000 nM
E4031). Apply drug again.
12. Click the GREEN-RED button to re-start Mobius to the end of experiment. (or add subsequent
phases with same procedure and run Mobius to the end of experiment.)
13. The Figure 4-5.4 shows the [Extract Spike Measures] module with added phase bars.
14. The analysis workflow including all analysis parameters and phase bars you set is automatically
made in the same directory as the acquisition workflow. Use this analysis workflow to make a
dose-response-curve later off-line. (Refer to page 148-150 for detailed instructions on how to make
a dose-response-curve.)

Figure 4-5.4. The [Extract Spike Measures] module with phase bars.

The phase bars can be added and saved to the analysis workflow even without extracting long spikes.
(Signals and analysis are not seen during recording in this case.) It is still recommended to perform
experiments without spike extracting unless you are very familiar with your experiment and preparations.
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4-6. Replay and analysis of acquired paced data
A Mobius data file (.modat) can be opened and replayed with the [Replay Raw Data File] module and
analyzed using various analysis modules. You will design your Analysis workflow by combining those
modules for replay and analysis of the acquired data.
The quickest way to replay and analyze the paced data is using the analysis workflow which was automatically generated when you run recording workflow with the Green-Red button. The analysis workflow includes the [Replay Raw Data File] and the analysis modules you selected for your recording.
The "Pacing_analysis" workflow template is also available to analyze the Field Potential Duration of
acquired paced data. This section will introduce you how to perform the FPD analysis using the workflow template.

4-6.1. Replaying acquired data
1.

Open the analysis workflow template.
1) Click [Workflow] > [New] > [From Template].
2) Select [64MD1_1280x1024] or [64MD1_1920x1080], depending on the size of your display
monitor.
3) Select [QT] > [Pacing_analysis] folders, then select the “Pacing_analysis” workflow template.
•

In order to open your own analysis workflow, click [Workflow] > [Open]. Select the analysis
workflow file (.moflo file).

Figure 4-6.1. Opening analysis workflow template.
2.

Click the box next to the “Filename” and select the .modat file. When the file name appears on the
box as seen on the right figure of the Figure 4-6.2, the data is ready to be replayed by clicking
Green button or Green-Red button.

3.

When the Green button is clicked, the acquired data is just replayed. Clicking the Green-Red button
execute the Exports or Saves which “Enable” check-box is checked.
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2

Figure 4-6.2. Opening the Mobius data file (.modat file).

Figire 4-6.3. Replayed paced data.

Input fields for the [Replay Raw Data File] module
1.
2.
3.
4.

Traces: Selects the trace(s) for processing.
Trace time: Selects the trace time for processing.
Channels: Selects the channels you would like to process. Click the box next to the “Channels” to
open the channel selector. Green channels will be processed.
Delay: Set this value to a value greater than zero to insert a delay between data "blocks" sent out
by this module. It is useful for delaying processing.
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4-6.2. Field potential duration analysis for paced cardiomyocyte signals
This section describes how to perform Field Potential Duration (FPD) analysis for paced cardiomyocyte
signals using “Pacing_analysis” workflow template. The workflow is available for the analysis of the data
acquired with the “Pacing_recording” workflow template.

Overview of the “Pacing_analysis” workflow template
The “Pacing_analysis” workflow template consists of following modules located in the “Main” and “Pacing measures” tabs.
Tab

Modules

Main

Replay Raw Data File / Display All Channels / Export Raw Data
Extract Long Spikes / Filter Spike Data (2) / Extract Spike Measures / Save Measures
Data / Display Extracted Spikes

Pacing measures

The replayed data is sent to the [Extract Long Spikes] module, where signals which go over pre-determined thresholds are extracted. The extracted signals are sent to the [Extract Spike Measures] module,
where amplitude, slope, time, and area are analyzed. (The extracted signals can be filtered out using
[Filter Spike Data] module before sent to the [Extract Spike Measures].
The raw data can be exported either as binary or ASCII data while the measurement chart is saved as a
"CSV" formatted text file.

“Main” tab
“Pacing measures” tab

Figure 4-6.4. Module configurations for “Pacing_analysis” workflow template.
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Replay Raw Data File
Display All Channels
Extract Long Spikes

Extract Long Spikes

Display Extracted Spikes

Export Raw Data
Extract Spike Measures
Filter Spike Data
Save Measures Data
Figure 4-6.5. Control panels for the “Pacing_analysis” workflow template. “Main” tab (left) and “Pacing measures ”tab
(right).

Field potential duration analysis for paced cardiomyocyte signals
1.

Open the “Pacing_analysis” workflow template (or your own analysis workflow), and then the data
file. (Refer to page 105-106)Replay the data by clicking the Green button, and then stop.

2.

Open the “Pacing measures” tab. Select a channel for spikes’ extractions. The default has all channels with “checked”. Click the check box to disable them. The setting can be applied to all other
channels by right-clicking and selecting [Apply to All].
•

It is recommended to select only one channel for spike extraction and analysis during acquisition although it is possible to select more than 1 to perform your analysis quickly and stably.

Figure 4-6.6. Extract Long Spikes module. Channel 17 is selected for extraction.
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3.

Set the thresholds by typing the number in the chart of Extract
Long Spikes. Set the thresholds to the location lower than the
depolarization spikes but higher than peak of stimulus artifacts
so that signals are extracted based on the stimulus artifacts.
(Figure. 4-6.7)

4.

Perform analysis according to the instruction in the 4-3.3. Field
potential duration analysis (page 113-121).
•

Make sure to set the first cursor between stimulus artifact
and depolarization spikes for analysis of FPD. (Refer to Figure 4-6.8)

Figure 4-6.7. Setting thresholds
for paced data,

Figure 4-6.8. FPD analysis with the “Time of Amplitude Min to Max”. Noted that the first cursor is located after the
stimulus artifact and before the depolarization spikes.
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4-6.3. Making a dose-response curve
This section will walk you through making a dose-response curve with the FPD from the acquired pacing
data. The Mobius' [Compute Measure Averages] module computes averages and standard deviations of
waveform analysis selected at the [Extract Spike Measures].

How to add [Compute Measure Averages] module to your workflow
1.

Open the analysis workflow which was automatically made when you acquired the data. (Go to
[Workflow] > [Open].)

2.

Add the [Compute Measure Averages] module to the analysis
workflow.
1) Create a new tab by clicking [Layout] > [Add Tab] and typing
the name for this tab. (Refer to Figure 4-6.9)
2) Open the new tab, and then open the “Mobius Editor” by clicking
[Workflow] > [Edit]. (Figure 4-6.10, left figure)
3) Click the [Extract Spike Measures] on the left “Workflow” box,
and then double-click the [Compute Measure Averages] on the
Figure 4-6.9. Adding a new tab.
right “Available task panels” box. Now you will see that
[Compute Measure Averages] module shift to the left “Workflow” box and the control panel for this
modules appears on the new tab. (Figure 4-6.10, right figure)
4) Click the [Compute Measure Averages] on the left "Workflow” box, and then double-click the [Save
Measure Averages] on the right "Available task panels" box. The [Compute Measure Averages] is
shifted to the left [Workflow] box, and the control panel for the [Save Measures Averages] module
appears on the screen.

Figure 4-6.10. Mobius Editor was opened in a new tab and the [Extract Spike Measures] is clicked (left). The
[Compute Measures Averages] was double-clicked and shifted to the left “Workflow” box (right). The control panel
for this. module now appears.
3.

Set the analysis parameters according to the instructions in 4-3.3. Field potential duration analysis
(pages 113-121).

4.

Run Mobius with Green button to replay the data to the end. You will see the phase bars you set
during your acquisition in the [Extract Spike Measures] module, and averages and standard deviations in the [Compute Measures Average] control panel. (Refer to Figure 4-3.37)
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If you work with “pacing_analysis” workflow template or did not add phase bars during recording,
add phase bars according to the instruction in the next section, “How to add phase bars”.
5.

The phase bars are shifted by clicking and dragging. The averages and standard deviations are
recalculated once Mobius is run with Green or Green-Red button after changing the locations of
phase bars.

Figure 4-6.11. The results of “Time of Amplitude Min to Max” with phase bars in the [Extract Spike Measure] (top)
and the averages and standard deviations for each phase displayed in the [Compute Measure Averages] control
panel.
6.

In order to save the average chart, save it as your own analysis workflow first. ([Workflow] > [Save
as]) Check the “Enable” check-box on the [Save Measure Averages] module, then run Mobius with
the Green-Red button. (Refer to section 4-7. Data output on pages 151-154 for details)

How to add phase bars
Even if phase bars are not added during recording, they can be added later off-line with following procedure.
1.

Set the analysis parameters according to the instructions in the 4-3.3. Field potential duration analysis (page 113-121).

2.

Open the “Measurement” tab, and then replay the data with the Green button. You will see the first
phase, Baseline (yellow bar) is already at time 0.

3.

When the first phase is finished, pause Mobius with YELLOW button, and make a new phase.
•

Select [Annotators] > [Add New phase], then, type the name for the new phase. (Figure
4-6.12)
Now you will see the new bar at the right chart of the [Extracted Spike Measures]. (Figure
4-6.13)

•

Do NOT stop Mobius with Black button. You will not be able to add more phases.
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Figure 4-6.12. (left) Adding a new phase bar.
Figure 4-6.13. (Right) A new phase bar on the [Extract Spike Measures].

4.

When the second phase finished, pause Mobius again and make a new phase.
*The location of the phase annotator (yellow bar) can be shifted later.

5.

Replay the data to the end. Averages and standard deviations are computed and graphed for each
phase (dose) in the Average tab. (Refer to Figure 4-3.37)

6.

In order to save the average chart, save it as your own analysis workflow first. Check the “Enable”
check-box on the [Save Measure Average] module, and run Mobius with Green-Red button. (Refer
to section 4-3.7. Data output on pages 151-154 for detail.)

Input fields for [Compute Measure Averages] module
1.

Channel:
The channel to be displayed is selected here. Channels can NOT be changed while running an
experiment.

2.

Use last:
If this box is checked, the selected (or typed) number of data points are used for computation. For
example, if 10 is selected, average and standard deviation are measured for the last 10 data points
in each phase.
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4-7. Data output
Mobius has several modules for data output of cardiomyocyte signals and their analysis. All analysis
results can be saved as “CSV” formatted text file with following procedures.
1.

Check the check-box for the [Save] module (Refer to page 151-152). File names can be modified
by directly typing them into the Filename modifier box.

2.

Select channels, Trace No, trace time for the saving in the [Replay Raw Data] module. Channels
shown with green will be enabled. (Figure 4-7.1)

Figure 4-7.1. [The Replay Raw Data File] ready for export. Data for 300,000-600,000 msec at channel 36 will be
saved.
3.

After setting all parameters, save the analysis workflow as your own. (Figure 4-7.2)

Figure 4-7.2. Saving analysis workflow.
4.

Run the analysis workflow with the Green-Red button. The output data will be saved in the same
folder where the analysis workflow is saved.

•

Refer to page 20-21 for exporting raw data.
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4-7. Data output

4-7.1. Save the measurement chart

Check the [Save Measures Data]. The measurement values in the [Extract Spike Measures] module are
saved as a “CSV” formatted text file.

File Format 20080210
Recording D2010/10/04 14:39:59 +09
TimeOfAmplitudeMinToMax(ms)
Trace#
Phase
Time (s) ch29
1 Baseline
1.531
148.3
2
2.136
161.4
3
2.74
159.65
4
3.344
158.2
5
3.946
155.4
6
4.549
158.1
7
5.152
152.35
8
5.755
153.2
9
6.356
153.15
10
6.956
158.85
11
7.557
158.7
Figure 4-7.3. [Save Measures Data] module/control panel (left) and example of the “Time Of Amplitude Min to Max
(ms)” for channel 29 saved as a “CSV” text file and displayed in excel (right).

4-7.2. Save the beat frequency data
Check the [Save Beats per Minute]. The beat frequency data is saved as a “CSV” formatted text file.
File Format
20071201
Session St 2010/10/04 14:39:59 +09
time_secs phase
10 Baseline
20
30
40
50
60
70
80
90
100
110
430.641 0100nM E4031
440.641
450.641
460.641
470.641
480.641

ch21
NC

ch22
NC
102
96
102
102
102
102
96
102
102
96
102
102
96
96
96
96
96

ch29
NC
102
96
102
102
102
102
96
102
102
96
102
102
96
96
96
96
96

ch30
NC
102
96
108
96
102
96
102
102
102
96
102
102
96
96
96
96
96

102
96
102
102
102
102
96
102
102
96
102
102
96
96
96
96
96

Figure 4-7.4. [Save Beats per Minute] module/control panel (left), and example of the beat frequency data for channel
21,22, 29, and 30 saved as a “CSV” text file and displayed in excel (right).
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4-7. Data output

4-7.3. Save the interspike interval data
Check the [Save interspike intervals] module. The inter-spike-interval data is saved as a “CSV formatted text file.
•

Select SINGLE channel to save ISI data which signals are NOT synchronized for all channels.
Otherwise, data will not be saved correctly.

File Format 20071201
Session St 2010/10/04 14:39:59 +09
time_secs phase
0.92355 Baseline
1.529
2.1335
2.7376
3.34125
3.944
4.5469
5.14945
5.7525
6.3536

ch21
ch22
ch29
NC
NC
NC
605.4
605.35
605.35
605.45
605.5
605.25
604.5
604.5
604.6
604.1
604.1
604.05
603.65
603.7
603.8
602.75
602.75
602.5
602.9
602.85
603.15
602.55
602.55
602.55
603.05
603
603.05
601.1
601.1
601

Figure 4-7-5. [Save Interspike Intervals] module/control panel (left) and the inter-spike-interval data for channel 21, 22,
and 29 saved as a “CSV” file displayed in excel (right).

4-7.4. Save the average chart
Check the [Save Measures Averages] module. The averages and standard deviations are saved as a
“CSV” formatted text file.

File Format Vers 20090613
Recording Date: 2010/10/04 14:39:59 +09
TimeOfAmplitudeMinToMax(ms)
Phase
ch29
+/-sd
Baseline
160.553
4.877
0100nM E4031
186.493
6.663
1000nM E4031
212.575
7.272
Figure 4-7.6. [Save the average chart] module/control panel (left) and the averages and standard deviations of the
“Time of Amplitude Min to Max” for channel 29 is saved as a “CSV file and displayed in excel (right).
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4-7. Data output

4-7.5. Save extracted long spikes’ waveforms
The waveform for extracted long spikes at selected channel and trace is quickly saved by:
1. Right click anywhere in the Raw data chart and select Copy.
2. Paste it to the Excel sheet.

.

Figure 4-7.7. Copying the extracted long spikes using Mobius (left) and the data pasted in an excel sheet (right).
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